Rust Server not listed (Dedicated Server)

Hey guys - so i try to explain what i already found out and what the issue can be (of what i think)…

Im a small Service Provider / Server Hoster in Germany, one of my Customer rented a Rust Server. He’s also from Germany.
All my Servers are running inside a Docker Container using the Software (Pterodactyl).

So i investigated a bit and checked the following:

  • Game-Server Port is 28015 (+server.port 28015)
  • RCON-Port is 28015 (+rcon.web true +rcon.port 28015)
  • Query-Port is not set
  • App-Port (Rust+) is 28082 (+app.port 28082)
  • Only UMod/Oxide is installed, no Rust:IO or any Oxide/UMod plugins

All Ports mentioned above are probably routed through Docker via TCP and UDP.
The Public-IP is reachable from nearly all places around the world.

With those settings, i can connect directly to the Server without any problem. Rust+ is also working fine. But even after several hours, the server got not listed.
Now, i tried to force the query port to 28015 which… didnt worked that well…
So i added +server.queryport 28015 to the Startup parameters and the Server started without any problems - but, i cant connect anymore and all listing pages cant reach the server either.
So i reverted this setting to the “default” (i removed the parameter).

I think it has something to do with the query port. But i really dont know.
It may also be a problem caused by Docker, because the Docker container dont know the public IP. But i cant set the +server.ip parameter in the docker container because the container dont know about this IP and cant bind to it.

So, i guess, its a) related to the game server boom or b) im having another issue with Docker the ports or whatever the heck is wrong with it…

I hope you guys can help me,
Regards
SeaLife

If you are running it in a docker, are you sure its set to public?
Is there a setting for that in the docker you are using?
I ask because i also run a server in a docker (unraid) and there is a setting in the package i use for public or not and the default i believe is not public.

Hey,

so i changed the following for my Server:

  • I changed the RCON port to 28016 (+rcon.port 28016 +rcon.web true)
  • I explicitly set the Query Port to 28015 (+server.queryport 28015)
  • Server port stays at 28015 (+server.port 28015)
  • App port stays the same (+app.port 28082)

After those changes and waiting for about 3 hours, my Server showed up in the Modded-Tab. :slight_smile:

So on my end, this seems to work.

There were no issues with using Docker, so i guess its either the changes i made or pure luck in the steam master servers…

King regards
SeaLife :slight_smile: