Rust sever on Ubuntu

I’m trying to run a dedicated **experimental **server on Ubuntu. I followed the manual here: https://developer.valvesoftware.com/wiki/Rust_Dedicated_Server

But when I run it:


Set current directory to /home/roberto
Found path: /home/roberto/Steam/steamcmd/rust_server/RustDedicated
Mono path[0] = '/home/roberto/Steam/steamcmd/rust_server/RustDedicated_Data/Managed'
Mono path[1] = '/home/roberto/Steam/steamcmd/rust_server/RustDedicated_Data/Mono'
Mono config path = '/home/roberto/Steam/steamcmd/rust_server/RustDedicated_Data/Mono/etc'

And nothing happens.

I know that when the files were not public this happened, but now that they are public why is it happening?

Thank you.

Are you sure you read the page you linked?

You mean the italic part?

If so, I apologize; if not, give me a clue about what do you mean…

That is exactly the part I mentioned, since I quoted it in my post.

Do you have any further questions about why you’re having trouble running the Linux dedicated server?

There is no linux support for rust servers at the moment, you need to host on windows or use something like wine.

No, I don’t, thank you.

I apologize again.

The linux server is being built and uploaded as far as I know

Thank you for the info.

Thank you Garry. Any details on how to setup on linux or link to linux server files?

This post need to be upgraded no?

@Garry please say something, Linux users need a minimum of help :frowning:

[quote=“tiruri, post:1, topic:216471”]

I’m trying to run a dedicated **experimental **server on Ubuntu. I followed the manual here: https://developer.valvesoftware.com/wiki/Rust_Dedicated_Server

But when I run it:


Set current directory to /home/roberto
Found path: /home/roberto/Steam/steamcmd/rust_server/RustDedicated
Mono path[0] = '/home/roberto/Steam/steamcmd/rust_server/RustDedicated_Data/Managed'
Mono path[1] = '/home/roberto/Steam/steamcmd/rust_server/RustDedicated_Data/Mono'
Mono config path = '/home/roberto/Steam/steamcmd/rust_server/RustDedicated_Data/Mono/etc'

And nothing happens.

I know that when the files were not public this happened, but now that they are public why is it happening?

Thank you
This may help you. I too wanted ubuntu but got this on centos. Check it out
www.vultr.com/docs/setup-a-rust-game-server-on-centos&ved=0ahUKEwjmmbqUpbzKAhUEPxQKHfWJC5oQFggnMAA&usg=AFQjCNFdgcXYVS4kCSlVVM6AB_t8OV0NIg&sig2=4Lk3yJ4ybqHu7IbYukCrUA

On the off chance that this post is still being watched, does anybody have any info on what prerequisites/packages are required to get the Linux server running? Been trying to get things running for a couple of days now and had no luck.

Some people have reported that they’ve been able to get it working, though. But nobody’s saying how.

Guys, can you please read what Garry said? The linux server is still being built and uploaded. We have to wait patiently.

I think you misunderstood, by that he meant that it is being built and released. We’re not currently waiting for it to be uploaded, it’s already there for download.

im struggling today , got linux rust downloaded and installed in ubuntu but i cant get a start.sh working

ignore why i quoted that post it was a mistake

just tried installing rust server using wine, just crashes. Unless I’m missing certain winetricks, i think its broken at the moment. I have visual C++ and glibc installed, do i need to install certain .dlls to get this to function properly?

Check this tutorial i made a few days ago, http://forum.facepunch.com/showthread.php?t=1503920

thanks man, i have it running and it uses less ram than on windows yay!

weird, that it runs better than when i was running it on windows.