Rust - SLI enabled = "alt+tab" really slow

Hey,

I have SLI and its enabled all the time pretty much, I don’t really want to disable it but I think im going to have to for rust until its fixed (Yes I know rust does not support SLI, but there is still something going on here)
Whenever I tab back into the game with SLI enabled, it more often than not, takes a very long time or so long that it causes my driver to crash and start back up.
I have tried the same thing with disabled SLI each tab out and in was fast and smooth, no issues there.

Anyone else running sli noticed this or a fix to it?

Specs if interested:
GTX 770x2 SLI
i7 3770k (@4.5ghz)
16gb ram 1600mhz
128gb ssd + 1tb hdd
tx850 psu

Driver:332.21

[editline]15th January 2014[/editline]

Would like to add the issue is only tabbing into the game, not leaving it.

still seeing if anyone knows anything about this :slight_smile:

meh ill bump every now and again to get some acknowledgement. Only fix is actually disabling sli everytime i want to play which i dont mind but if i forget and tab into the game i will get a crash for 5-10sec and driver reset. which as stated does not happen if its disabled.

Are you sure your computer chipset is an actual SLI supported chipset ? what kind of chipset you have ?

erm yes, i’ve used SLI for months now. using p8z77 v-pro mobo. has 2 pci-e 16x slots. I know my sli works fine.

If you know anything about SLI a lot of games dont run efficiently with it as they would with a single card. Especially rust due to how god awful unity is

Unity is great

it’s because of how rust is being made

I’m running dual gtx660s in SLI and everything is smooth for me, dunno whats going on there

Make sure your plugged in when playing, really helps power usage!

As for the crashing…meh, doesn’t happen to me, but when I press alt+tab its really slow.

(Specs:)
Intel i7
755m SLI
16GB Ram
256gb SSD (1TB External)

Edit:

Close steam and try running as administrator and then log back in and see what happens. Should help.

Double Edit
Nice PC specs. (4.5 GHZ) eeeeeeeeeeeee!

SLI does not work in Rust, otherwise GPU2 would not be sitting on 0-5% on Afterburner, while other games the utilization is shared evenly.

Alt-tabbing does that, SLI or not, right now. Run in windowed mode or don’t alt-tab.

It doesn’t for me thats what im saying. Disabling SLI makes a smooth tabbing in experience, where as with SLI enabled my driver would more often than not crash and restart and then tab into the game. (i have tested tabbing in over a 100 times without SLI to make sure of this)

[editline]25th January 2014[/editline]

I did not think it would make a difference at all? Since rust does not support SLI at all, the second card is not being used at all, and yet im here with this annoying problem :confused:

[editline]25th January 2014[/editline]

I know this, that is why i’m asking whats going on, first time i’ve had an issue with SLI and it’s on a game that doesnt support it o.o

[editline]25th January 2014[/editline]

Can you tab into the game fine? with the issues I get it would take around 10 sec to tab in.

[editline]25th January 2014[/editline]

Plugged in when playing? xd I am on a desktop mate.

If you want to test, disable your SLI and try tabbing into the game and see if there’s any difference.

and thanks :slight_smile:

[editline]25th January 2014[/editline]

Sorry been busy just replied to most of the comments above

Check your Rust console when that happens, in SLI.

If you see the “Gfxdevice is in invalid state” type of message, that’s the driver crashing.

Rust and SLI don’t behave well in general, but some people get this problem just from alt-tabbing and the driver crashing on switching out of Rust and back to the desktop/taking Rust out of minimization.

Well I just did it again to check and nothing as such came up in the console, just something like Stopped rendering which i dont think is to do with it.

It get’s pretty bad, first time I did it just then, my firefox crashed etc because of driver crash and reset, second time I did it same crash again but for longer and was almost frozen for a while.

Alternatively i’ve been tabbing by using alt+enter to go windowed mode then change back but that sucks to do.

I can add that it only happens while actually in a server, doesnt happen on the server list screen.