Rust Using Intel Graphics And Not dedicated GPU

Hello, Rust doesn’t detect my dedicated GPU (GeForce 740m)

I’m on Windows 8.1 and tried all these solutions:

  1. Try to run “rust.exe” and rustclient.exe directly with the dedicated graphics card. (didn’t work)
  2. Change in the NVIDIA control panel “steam.exe” “Rust.exe” “Rustclient.exe” in 3D settings.
  3. Added this registry key (https://www.reddit.com/r/shadowofmordor/comments/2i6jg9/solution_to_nvidia_mobile_gpu_problems_with/)
  4. Used NVIDIA Inspector.

I don’t know what to do, please if someone has some solution, please share that here.

PS: I forgot to say i’m on a Laptop (Asus X750J)

Go into Device Manager and disable the integrated device. Do not delete it.
Your dedicated card will be used by default by everything.
BAM!

Right-click on the desktop and set the default graphics adapter to be the 740M.

Right click Rust.exe and run it using the nvidia processor.

Done, but the system chooses an even worse video card.

I’m on Windows 8.1, I really don’t see that option, the only thing I can do is open the NVIDIA control panel or Intel panel

If I run Rust.exe don’t work, but if I run the rustlauncher.exe works, but I can’t connect to any servers because EAC is not connected.

Thanks for the help guys but I still can’t select my NVIDIA GPU in Rust… Any other suggestion is welcome and appreciated

What other display adapter could you possibly have?
I’ve done this exact trick several times on several different systems and it never fails.
My techie-sense is telling me this is likely a user error issue.

Hello No Quarter, thanks for your answer.

The driver I got when I disable the Intel one is “Microsoft Basic Display Driver” Mabie I should try to disable this too?

Thank you again

If you disabled the Intel adapter and it’s defaulting to ‘Basic Display Driver’ then your computer isn’t not properly using your dedicated card.

It means either the system is not properly recognizing it, or… you lack the proper display drivers.
I suggest reinstalling your nVidia drivers then a quick reboot.

If it doesn’t recognize your newer, dedicated card then I suggest seeking more professional assistance. Unless someone can check all your settings there’s very little help this forum can offer you.

I have the same problem. I am using Dell xps 17 gt555m and I can only play with dedicated card using rustclient.exe, but it gives me EAC:unconnected.

go into the Nvidia Control panel then go to 3D settings - Program Settings, and press Add and find rust.exe (in steam library) now tell it to use the global settings or to directly use Nvidia Processor with high performance… jobs done if you cant do this something is wrong

Doesn’t work.

go in nvidia panel and select as default : nvidia high performance

i can change all the settings in nvidea but it doesnt work it still uses intel.
How do i change default graphical adapter in windows 8.1?

Just google the guide for your GPU (Nvidia e.g.) and your notebook name

yah i did all that not working :(. Dunno why rust jsut keeps using the intel gpu.

I’m guessing y’all aren’t properly disabling it in Device Manager.

Maybe that will help abit:
http://forum.facepunch.com/showthread.php?t=1478825