Rust wont launch via Steam

I’ve tried a bit of everything over the past few days, including reinstalling my entire system (Windows 10). Whenever I go to launch rust, I select “Play Rust”, then nothing happens. I notice that in my library it shows that rust goes from “Running” then to “Syncing” then finally nothing.

When I start RustClient.exe, it works… Although this is pointless as EAC won’t run… Which is why I believe EAC is causing my issue. Rust.exe doesn’t run.

Steps I have taken:

  • Restarted system
  • Reinstalled OS and all drivers
  • Updated windows
  • Start Steam as Admin
  • Installed Steam in x86
  • Attempted an old registry fix found on the net
  • Reinstall of EAC manually
  • Verify Integrity of game (multiple times)

Rust worked perfectly fine before the update, and all my other games launch no problem.

Any input would be great… I just recently went on vacation from work… and boom… no rust D’:

Wait for the next update.

We have released an anti-cheat update this morning that may fix the issue you’re experiencing.

Could you see if it works for you now? If the problem still persists, could you add me in Steam Friends (https://steamcommunity.com/profiles/76561197999579793) for troubleshooting it further?

Also having the same problem, still not working after the anti-cheat update.

Added you on steam :slight_smile:

have you tried restarting your computer?

Yeah, tried that first, also reinstalled EAC twice.

Rust starts from local files without EAC, but not through steam.

@Notalotscott, thanks for adding. Do you get any error message, does the game start to the options or just silently closes?

Hey, the game just silently closes through steam, works ok using the steam.exe, but no EAC, so can’t connect to servers.

I’ve verified integrity of game files, also reinstalled the game and tried disabling the antivirus.

I’m using vista 64 bit, the game worked fine after the flamethrower patch last night.

Gotcha, thanks. Let’s continue via Steam Friends and get it fixed asap!