Rust won't start, can't terminate process either

So I just updated Rust, and now when ever I click play on steam, nothing happens, however when I check Task Manager, the processes are there. They can’t be killed though, i’ve even tried using the command prompt. Closing steam doesn’t help either. I’m forced to restart the computer. I’ve tried verifying the game files, I’ve tried running them as admin directly from the game folder, and it gives me the same problem. My drivers are up to date. The game was working completely fine before the update. Any suggestions?

  • Same problem

Me too.

I’m having the same issue. Rust doesn’t need me to launch the game when I restart my computer;
the process for rust is already running. Process won’t let me close it of course…I deleted and reinstalled Rust just now, to no avail. Same issue is persisting. Please help.

this is EAC

Hi,

We’re really sorry about this happening to you. :confused: We have reverted the latest anti-cheat update, but you may need to restart Windows once in case the game process is not dying / stays in the task manager.

Could you see if you’re able to start the game normally now? Thanks!

Is there going to be a patch that we will need to download thou steam??
There’s alot of people that are having the same issue and have been waiting for dev’s to reply to us all day.

I just validated the game files, it said 1 file needed to be downloaded again. So it did, and now the game started. Thank you!

I have always my problem

http://image.noelshack.com/fichiers/2016/14/1460115930-gdhddffh.png

did you restart you computer?
i validated after i removed EAC and still can’t play

Nope, I didn’t restart my computer, I didn’t remove or add anything to my game files either, only validated.

I restarted computer and ran in DirectX 9. Worked.

I do what did you say but the problem is always here

[editline]8th April 2016[/editline]

that doesn’t work for me

Yeah, i restarted my computer, validated the game. I’m still having the same issue as before.
I don’t know how you can download a 0 bytes for Rust and it works.

@TheGuesh, do you have Emsisoft Anti-Malware or Trend Micro anti-virus?

It actually downloaded something with a size of 128 bytes, not 0

Nope didn’t work for me either

[editline]8th April 2016[/editline]

Ive got Trend Micro anti- Virus

[editline]8th April 2016[/editline]

see i don’t understand how you can download 128bytes and I can’t

Yes TY i delete my demo of Emsisoft Anti-Malware and that’s ok now :smile::goodjob:

Imgur

this is whats happening to me

[editline]8th April 2016[/editline]

Eac Knubbe,
so do i have to delete me Trend Mirco anti virus software to play rust? or are you guys working on a patch now for it?

We’re currently working on fixing the compatibility with Emsisoft Anti-Malware and Trend Micro anti-virus. Unfortunately both of them suffer currently from a bug that causes their user-mode hook component to crash the process. We’re making a work-around to this, to avoid the crash and have it working again for you asap.

Sorry for the wait on this, hopefully we can release an update fix by next Monday.