Rust won't start

When I start rust it pops up like start service failed error 31 please help

http://forum.facepunch.com/showthread.php?t=1500582&p=49483256&viewfull=1#post49483256

Hi guys,

I am new to the community, and I bought rust last night via Steam, I updated it and after trying every trick in the book that the online community offered, (updating unity player, setting admin rights, re-installing EAC, disabled my anti virus, etc). Yet I am still left with a game that doesn’t load up, due to this error:

"Unity Player [version: Unity 5.3.1p2_49544457ab1d]

igdumd64.dll caused an Access Violation (0xc0000005)
in module igdumd64.dll at 0033:e839328f."

Please could you advise me on what to do as I am very disappointed the game doesn’t seem to work for me, I have attached the error log within this message in hopes you can understand my problem better than myself, this error also appears every time after i’ve joined a server and the load bar states ‘loading monuments’, then CRASH, everytime. I am happy to provide more info to anybody willing to help, as I really just wanna start roaming naked with my pet rock…

Thanks,
Alex

STOP. Just stop. you are posting this same post everywhere thats not going to help its called spam.

I have now made my own thread, and I am only posting it in threads with similar issues in hope somebody can help me, to be honest after reading the forums I thought you guys were a friendly bunch but it seems i’m going to have to be a bit more careful with you guys. Woosah, its just a forum, i’m sure one more reply on any thread won’t harm anybody, but I will take your advice with a pinch of salt.

rules are rules all the time or they wouldnt be rules.

try googling “igdumd64.dll Access Violation”

Sorry I didn’t know, i’m new to this whole shabang and just really wanted to get going with Rust so I can chase stuff naked without getting arressted as I do in real life…

Thanks bud but i’ve already tried that and it doesn’t seem to be a common theme :confused:

well i just tried it and spent 2 minutes to find this. you can read it all or basicaly summe either

  1. you have a virus. Get rid of it. AND OR
  2. your HDD is bad. Scan disk it.
    concludeing in… the file is BAD and needs replace.

Causes of Igdumd64.dll Errors
Most igdumd64.dll errors are related to missing or corrupt igdumd64.dll files. Because igdumd64.dll is an external file, it presents a great opportunity for something undesirable to occur.
Improperly shutting down your PC or getting a virus infection could corrupt the igdumd64.dll, which could lead to DLL errors. When your igdumd64.dll file becomes corrupt, it cannot be loaded properly and will present an error message.
Other times, igdumd64.dll file errors could be related to issues in the Windows registry. Broken DLL file references can prevent your DLL file from registering properly, giving you a igdumd64.dll error. These broken registry keys can be as a result of a missing DLL file, moved DLL file, or an leftover DLL file reference in your Windows registry from an unsuccessful software installation or uninstallation.
More specifically, these igdumd64.dll errors can be caused by:
Invalid or corrupt igdumd64.dll registry entry.
Virus or malware infection which has corrupted the igdumd64.dll file.
Microsoft hardware failure, such as a bad hard drive, which has corrupted the igdumd64.dll file.
Another program overwrote the required version of igdumd64.dll.
Another program maliciously or mistakenly deleted the igdumd64.dll file.
Another program uninstalled the igdumd64.dll file.

Hi,

I have found the same article just now, my apologies, before when I looked I was just waking up and didn’t spot it, I am currently running a ‘sfc /scannow’ scan via command prompt, however, I have already ran a virus scan this morning and nothing, so i’m starting to think its more of a corrupted/missing file issue?

Should the scan confirm this, where is a reliable place to get replacement DLL files? Microsoft themselves?

Thanks,
Alex

google is your best friend mate.

ok how to fix this i google it and no clue

I’ve found multiple suggestions, the command scan said ‘windows resource protection did not find any integrity violations’, so I am now going to try a suggestion that says to disable games in windows feature, reset and repeat, failing that i’ll try the DLL file replacement.

Thanks for your help man

id just follow the steps listed there from step 1 first

Stupid question (probably), tried more or less everything I feel is going to help and am just tweaking the graphic settings before entering the game, does the ‘x’ mean the setting is ON or OFF?

x means on

FIXED:

anybody needing help with a similar issue give me a shout,
but basically:

Turn Intel HD settings all to performance for better speeds
Defrag Hard Disk
Run task manager and end any unneeded tasks
Run Rust on lowest settings possible with details in link below:
(article: http://forum.facepunch.com/showthread.php?t=1494248&p=49543142#post49543142)

Hold your head in shame as you realise you should’ve bought a new laptop/PC ages ago

alex can u contact me on steam

guys can u please help me how to fix when i start it says start service failed error 31

gtmod already posted the fix - have you tried that yet?

yeah but i don’t have AVG