RustClient.exe - Application Error - new laptop (Razor Blade)

I have a new laptop - Razor Blade gaming laptop with Windows 10 and it is fully up to date. I am only running the Antivirus software that comes with Windows 10.

steam installed and updated Rust without problems.

when I start steam and click on Rust and I get to the point of picking the Rust Server and the client launches, I see it loading entities ,etc. than eventually it stops and generates a dialog

“RustClient.exe - Application Error”
“The instruction at 0x00007ff626c8ebe references memory at 0x00000000001AD0. The memory could not be written.”

Click on OK to terminate the program.

help!

  • yes my NVidia GTX970M drivers are up to date.
  • yes I tried launch from Nvidia game launcher, from Steam and from the EXE directly.
  • yes I tried windows and full screen

I have almost exactly the same hardware specs with the same error occurring, except i’m using an Alienware 17 R3.

I have a feeling it has something to do with the dual-graphics, but has anyone found a resolution to this issue with this very specific hardware configuration?