Rust's Window Focus Bugged (for me)

First of all, no, I’m not referring to some DoF thing with windows in game. I’m referring to a terrible bug causing the Rust’s window to flash. Since the people on Reddit seemed to be a little stumped by my issue, I decided to come here. Notify me if this is the wrong forum please.

I’m currently experiencing, as I’ve said, a bug that makes Rust basically unplayable. Basically, whenever I click, there’s a chance that the screen will focus on whatever is BEHIND Rust’s window, causing the next click to instead focus back on Rust’s window and not perform a click in-game, thereby making shooting extremely difficult.

Here’s a video of it happening (excuse the quality): https://youtu.be/3Cv0LCh0PGE

As you may see, I’m manually shooting an M249 to show the effect.

What I’ve tried to solve the issue so far:

  • Reinstalling Rust

  • Launch Steam as admin then play Rust

  • Use various launch options involving max memory and process priority

  • Verifying integrity of Rust’s cache

  • Unplugging second monitor

  • Not having any window open in the background (showing desktop only+Rust)

  • Launching Rust in windowed mode

  • Launching Rust in directX9

  • Launching Rust in directX9.3

  • Changing various options within Rust

  • Attempting to force Rust into true fullscreen (couldn’t figure out how to do that)

  • Playing other games, especially those using Unity and are in borderless-windowed mode (like Rust) and seeing if they had the issue too (they didn’t).

  • Praying an update would fix it (it didn’t)

  • Downgrading GPU drivers (might have done this wrong!)

  • Putting Rust on HDD instead of SSD

  • Running Legacy Rust to see if it had the same issue (it did!)

  • Forcing OpenGL through launch options (or was it CL?)

  • Complaining to my friends

Another important thing to notice is that this only started happening right AFTER I removed 1000 pieces of malware (no joke) from my computer after attempting to ahem install some important software for a project and failing to click the right download button (I have it now). The viruses are completely wiped it seems, after numerous scans and checks of my processes. What did happen is that the viruses changed some of Window’s settings like confirmation to run applications in administrator mode, but I did change back.

What I’m suspecting happened is that something in my registry changed or another setting I’m unaware of got switched.

TL;DR: I have a cancerous bug causing ONLY Rust’s window to bug out while playing. I’ve tried basically a million things and not one solution worked. It’s started after I removed a bunch of viruses on my computer that I had for only about one hour total (immediate removal).

If anyone can provide help, I’d greatly appreciate it. This issue has been preventing me from playing Rust for far too long. Thanks!

It’s only caused by left-clicking as well. Nothing else will trigger the bug. I’ve considered binding left click on my Logitech mouse to press something like the END key for only Rust (using Logitech gaming software), as it’s almost never used; I realized that it wouldn’t work as I must left click to perform actions like opening menus and moving items around my inventory.

One of the problems is that RUST DOES NOT GO FULL SCREEN it merely goes to borderless windowed. That’s why you can see that shit popping up without rust minimizing and freaking out.

If Rust went true full screen we would all get a nice lil performance boost also. Not sure why we don’t have it.

I understand that Rust does not truly enter full screen. That’s why I searched for ways to force it. Also, the reason we don’t have full screen is that Unity running in DirectX 9 does NOT send packets while minimized, causing a rapid disconnect to those that alt-tab. I believe I remember it being this way in very early experimental, but that’s all I know.

Didn’t know that, but I do remember Rust used to go full screen so now that makes sense.

Have a try at using this:

I don’t need that, considering Rust is already in borderless windowed mode. I’ll see if it can force fullscreen though.

Edit: Just tried it and it didn’t work. Thanks for the advice though.

Just thought maybe that would help force it to be at the forefront. How does it play if you have the taskbar set to autohide or similar?

Edit: Nevermind just noticed in the video it’s your entire screen messing up