Save does not load base.

I have been working casually on a base over the past two weeks. Recently upon saving my progress and returning back to it another time it will not display any items whatsoever but will allow me to load older working saves. I have also tried saving multiple times - saving every hour or so as I worked - but each-time I would reload back into a empty map with no sign of a prop in sight. I even tried publishing my work and tried loading from there but the result was the same.

Does anyone know why this is happening? Its beginning to become frustrating.

Can you attach a save file of working and not working save?

Here are the saves I’ve published, include the working and unworking saves: http://steamcommunity.com/id/bones456/myworkshopfiles/

I think I know what is going on, I will have to do some more testing, I will let you know if I find out what happens and possible fix if I come up with one.

So far I can tell you only the fact that it seems that you will not be able to save maps with tons of props/constraints on it. All your “unstable” saves are corrupted and do not contain any save data.

I had a suspicion it might be because of too many props, as previous attempts when adding a front gate always ended up with the save not working. But when saving it always seemed to put some effort into compressing the save up with no sign of error.

Ok, I was correct, any save that is bigger than 64KB compressed will fail to save. I will see if I can whip out a fix for this.

[editline]9th February 2015[/editline]

Same goes for duplicator.

If you manage to get the save working that would be great. This is a better look of it for those interested: https://dl.dropboxusercontent.com/u/11648828/JUNKBASE2.png

Fixed for next update.