SCars 2.0

[h2]About[/h2]

Don’t like normal hl2 vehicles?
Then this addon is for you!
With SCars you can customize your car in almost any way you want.
Everything from paintjob and handling to suspension height.

Didn’t like version 1.3?
Then give version 2.0 a try!
Pretty much everything was remade from scratch.

SCars 2.0

Old SCars
[media]http://www.youtube.com/watch?v=2nYVgiudPqA&feature=player_embedded

Misc Pics

[h2]Controls:[/h2]

USE: Enter or leave the SCar.
WASD: Moving.
SPRINT: Turbo.
PRIMARY FIRE + A or S or D or W: Use hydraulics separately on the wheels.
SECONDARY FIRE: Toggle the hydraulics.
JUMP: Handbrake.
Walk(Move slowly): Change seat.
JUMP + W: Rev engine.
W + S: Burnout.

Want to change the controls? Go here!

You can change all sorts of stuff for SCars in this menu.
Camera type, hud, admin limitations…
You can even add your own URLs and use them as radio stations.

[h2]Instructions:[/h2]
Most of the stuff should be self explanatory but if you need some more info I suggest you download
the User Instructions & Developer Tutorials. You will find a download link at the bottom.

[h2]Download[/h2]

You must be logged into steam in your web browser in order to be able to view these links.

Slim: Only the stuff you really need. 3 Cars
Steam Workshop: http://steamcommunity.com/sharedfiles/filedetails/?id=104483020

Basic: The cars from 1.3. 25 cars (YOU STILL NEED SLIM)
Steam Workshop: http://steamcommunity.com/sharedfiles/filedetails/?id=104487316

Extra: More exclusive cars. 27 more cars (YOU STILL NEED SLIM)
Steam Workshop: http://steamcommunity.com/sharedfiles/filedetails/?id=104492363

User Instructions & Developer Tutorials
Gamefront: http://filesmelt.com/dl/Saved_SCar_content.zip

[h2]FAQ[/h2]

Gmod crashes when I start Gmod
There is nothing I can do about it. The content that comes with SCars won’t even load or run until you start playing a map.
If you can’t even get to the menu the SCars content won’t even be loaded. In other words the problem isn’t SCars.

Gmod crashes when I download SCars
There is nothing I can do about it. The content you are downloading won’t run until you start a new game.
You can’t run it before you have finished downloading it which means that if you crash while downloading there is nothing I can do about it.

There is nothing in my SCar tab
You got too many addons installed. This is a weird issue that is caused when you got to many addons installed.
Can’t do anything about it since it’s decided by limitations in GMod which I can’t change.

My wheels, cars or parts are missing/invisible
I’ve never experienced this issue myself. People say that mounting certain games in GMod can cause this issue.
Try to disable some and see if you get any result.

How do I turn the police lights on?
There is a key called “special key”. It’s B by default and it’s just an extra key some cars uses.
Police cars use it to turn the sirens on and off while the DeLorean uses it for both toggling hovermode and time travel.

How does the DeLorean work?
There is a key called “special key”. It’s B by default and it’s just an extra key some cars uses.
If you press the special key while holding W at the same time you will start the time travelling function.
If you just press the special key while not pressing any other keys you will toggle hover mode.

How do I open the car editor?
Go to the Utilities tab. Locate the SCar category and press on SCar Editor. A button should appear. Press it to open the editor.
You can also hold down the context menu button and press the SCar editor Icon.

My third person view doesn’t work!
Are you pressing the correct button? The default button to switch view in SCars is V.
If you are pressing the correct button and it still doesn’t work you probably got a conflicting addon installed.
There really isn’t much I can do about that. Basically what happens is that some other addon is overriding my camera.
The only solution is for you to find out which addon is overriding it and then disable/uninstall the conflicting addon.

SCars is broken for only me, I get a crapload of errors
You should probably clean up gmod.

[h2]Credits[/h2]
Sakarias88 - Scripting
TiggoRech (lots of models)
Kazzim - Ideas and beta testing
( ^_^)/¨ - Ideas and beta testing
Mr.Bix - Beta testing
Splayn - Car Models
Mihara - Skin switcher stool
Karmah - New/fixed car models
Griba - New/fixed car models
Overv - menu help
Thunder Skunk & Cookie - Vigilante 8 cars
ApwnInTheDark - ripping & converting boarderlands bus.
Sgt.Sgt - Ported GTA Models
alexojm Gas station model
Kirbyguy222 the ilcar
Ace00731and Nirrti the DeLorean
All the other beta testers.

Does this work with CPPI, yet?

I just uploaded the patch a min ago.
Should work with CPPI now.

which of us is going to test it?

I am going to test it on srcds real quick, lol.

edit:
doesn’t work :frowning:
car is world prop and wheels are disconnected player’s prop.

Odd. Worked for me when I tested it just before I uploaded it.

[img_thumb]http://oi49.tinypic.com/6zsns4.jpg[/img_thumb]

[img_thumb]http://oi48.tinypic.com/e3x51.jpg[/img_thumb]
Yep, still works here.

Just noticed that I still got some old set owner code left.
Maybe that’s messing it up. Will have to fix that once I get home.

SCars isn’t compatible with Environments.



SCars is getting some really weird errors that shouldn't occur.
Message: 
Ever thought about cleaning up GMod? You probably should!


Then I die and my body floats away with a “#World” killicon.

also make sure you have the very latest FPP

sure thing, I’ll test when I get home.

That is another mistake that I’ve made. I’ve been in a hurry when making these patches.
The thing is that if you get that kind of red text there should always be something after “Message:”.
In other words it shouldn’t be displayed at all. It’s a false alarm.

I made that message so I can prevent some silly errors users create.
Like when the string.Explode function is missing (attempt to call field ‘Explode’ (a nil value)).
I thought that if they manage to mess up GMod so badly they should probably clean it up.

Will see if I can make another patch today (without any silly coding mistakes).

it’s ok, mate, noone’s perfect.

How would I go about adding custom sounds to SCars? Before you just stuck it in the addon’s sound folder, but what now?

If you put your sounds to a “special” folder they should be automatically loaded.
Here is the directory! Dir: “SomeDir/sound/scarenginesounds/”.
Should work if they are placed in a separate addon, should also work if the sounds are placed in the garrysmod/sound/scarenginesounds/ directory.
However if you got any other OS besides windows it probably won’t work at the moment.
I just checked the code and noticed that I used some capital letters in the directory.
As you may know other OSes despite capital letters and instead they either wont recognize the directory at all or they say that
everything is all fine and dandy but once you load the file there is no content to read.
Can I fix it? Yes but I won’t upload another update with such a small change unless it’s a big problem.

Also, if you want to add new horn sounds putting them in this dir should work “sound/scarhorns/”.

This autoload feature should still work. If it doesn’t please tell me.

Some people have a lot of addons installed like Wire and CAP that use a lot of SetNWInt and SetNWString an such. If SCars is mounted after them, and there is no more room in the net table, invisible cars from STool and empty premade car list are both symptoms.

We need to take this up with Garry, so he could add a CVar that allows one to expand the networked variable table…

What happend to the garage you showed off on YouTube?

Finally. I’ve wondered why people get these kind of issues.
Yeah we probably need to take this up with Garry or at least find a solution to this problem.

I’m trying to download your “Slim” pack, I’m logged into the Steam Community and each time I click on the link, it’s redirecting me to my Steam profile homepage.

you may want to contact steam about that.

I love this addon, one of the very first I installed and had it ever since! I have never had a problem with it (apart from neon lights which I still can’t figure out why they don’t work) and it got to be one of my most used addons. Using this addon on gm_bigcity with a load of friends in a Skype call is awesome. I highly recommend this addon!

Ideas

  • Adding a weapon (50 .cal?) to the roof of the Humvee which can be controlled by a player
  • A seat in the back of the pickup trucks
  • Light colour changer, so when you turn on your cars lights on they are the colour you selected e.g blue
  • Lotus Espirit S1, featured in the James Bond movie, could have a special ‘abillity’ like the Delorian which is to go under water

Keep up the good work!

This addon does not seem to work for me anymore, i mean i have it installed and such in the addons folder but when i try to retrieve it in gameplay i just get this

http://cloud-2.steampowered.com/ugc/560969538421030847/029F65252D0E41A248C7E5D3ED6D489FE168F984/

I’ve tried these methods of trying to fix it

putting in a one downloaded from gmod banana rather than the workshop, didn’t work

Deinstalling and reinstalling, Didn’t work

Removing wiremod, Didn’t work

adding a legacy Gmod 12 scar’s didn’t work

It’s a little frustrating that once upon a time this worked perfectly now it doesn’t XD, too good of a addon to be spending half it’s life broken tbh