Scoreboard Glitched

Hi,

I’m experiencing some weird bug that occured basically out of the blue after a restart, and i have no idea how to fix it.

When ever i’m (Or other players) press tab, it says “Something is creating scripting errors” and the scoreboard sticks to the screen (+ It doesn’t show the online players but youself)

This is what it pints into the console:


[ERROR] gamemodes/terrortown/gamemode/vgui/sb_team.lua:76: attempt to index global 'sboard_panel' (a nil value)
  1. unknown - gamemodes/terrortown/gamemode/vgui/sb_team.lua:76

Here is line 76 in sb_team.lua



   -- Column darkening
   local scr = sboard_panel.ply_frame.scroll.Enabled and 16 or 0
   surface.SetDrawColor(0,0,0, 80)
   if sboard_panel.cols then
      local cx = self:GetWide() - scr
      for k,v in ipairs(sboard_panel.cols) do
         cx = cx - v.Width
         if k % 2 == 1 then -- Draw for odd numbered columns
            surface.DrawRect(cx-v.Width/2, 0, v.Width, self:GetTall())
         end
      end
   else

As i said, it came out of the blue, it was broken after i restarted the server. Also, i restored a backup from a few days ago, same error. I have no idea what’s wrong with it.

I hope someone can help with this :slight_smile:

//U…Words

Fixed it. it was scorebordranks that broke or something…