Script Errors with Pointshop

I get this error on my server several times each round depending on how much players are on the server.



[ERROR] addons/pointshop-master/lua/cl_player_extension.lua:70: bad argument #1 to 'ClientsideModel' (string expected, got nil)
  1. ClientsideModel - [C]:-1
   2. PS_AddClientsideModel - addons/pointshop-master/lua/cl_player_extension.lua:70
    3. func - addons/pointshop-master/lua/cl_pointshop.lua:93
     4. unknown - lua/includes/modules/net.lua:30


I have tried fixing it several times, my pointshop is up to date. Some notable things are that I deleted the weapons folder, deleted the supersize and supersmall power ups, and as well as added my wubber boots for power ups. Everything is the same besides these. These are the files that the error is referring to:

cl_player_extension
cl_pointshop.lua
net.lua

Post your wubber boots code.

Here it is wubberboots.lua

You need to define ITEM.Model

Where/what exactly? and how would I do this? My lua capabilities are not the finest.

Remove ply:PS_AddClientsideModel(self.ID) and ply:PS_RemoveClientsideModel(self.ID) from OnEquip and OnHolster.

That did the trick, and I have learned. Thank you very much I appreciate everyone for helping!