Scripted Brush Entity (Not Working)

This is my scripted brush code:
[lua]ENT.Base = “base_brush”;
ENT.Type = “brush”;

function ENT:StartTouch(ent)
print(“start touch”);
end

function ENT:EndTouch(ent)
print(“end touch”);
end

function ENT:Think()
print(“think”);
end

print(“alive”)[/lua]

I put the alive print outside of all the hooks/functions of the entity, and guess what? It printed.
But none of the other text ever prints, not even the one in the think hook???
I can’t figure out why. It’s placed in Hammer, I’m 100% sure. Of course it has no keyvalues or flags or anything but it’s there, and was compiled (I think?) and it’s a trigger brush texture just tied to an entity that’s class is set to the same one as my scripted brush.

I basically did the same thing back in 2014, haven’t looked at the code since but it worked at the time and noticed it’s different to yours:



ENT.Base = "base_entity"
ENT.Type = "brush"


No difference… :cry:

“base_entity” - “base_brush”

Really, no difference?

Uhh, I have this too:



function ENT:PassesTriggerFilters( entity )
	return true
end


But wiki says ‘this hook is broken’

Add a print in ENT:Initialize. If it does not print from there, the entity is not spawning ( Check class names ). Also worth mentioning that you should be looking in the server console.

Otherwise your code seems valid, you are deriving from the correct base.

It’s not spawning it seems.
Is there anything I should do in Hammer besides make a trigger brush and then tie it to an entity of the same classname as the scripted brush entity?

You are most likely misspelling the class name or some shit.

edit: wait what i misspelled the original entity???
well i tried copy pasting it into the hammer window just to make sure they were 100% the same but it seems it didnt copy paste right so…
solved

http://i.imgur.com/zSL8Xa3.png

http://i.imgur.com/eZvkRgV.png

Are you for real