Segmentation fault on startup

Hey guys,
my server is running on Linux Debian 6.0 Squeeze, and it was running for the last 3-days without any problems on DarkRP with 40-players
Today it crashed somehow, then I tried to restart it and got “Segmentation fault”

Whats the problem? And where do I find the debug log?

Also tried to change libs etc.

PS:
Had this problem a while ago on my cinema server, and because there was not much custom/dynamic content i just reinstalled it and it worked (I mean, i dont know what happens if it crashes - cause the server is running for a few days now) - but I cant do this with my DarkRP server…

Push?
Can someone please help me? please :frowning:

Server runned for 3-days, then closed the screen und opened it again; getting this in console:


Auto detecting CPU
Using default binary: ./srcds_linux
Server will auto-restart if there is a crash.
Using breakpad minidump system
Using breakpad crash handler

Console initialized.
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "�f��"
Setting breakpad minidump AppID = 4000
Forcing breakpad minidump interfaces to load
dlopen failed trying to load:
/home/gmod/.steam/sdk32/steamclient.so
with error:
/home/gmod/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
PreMinidumpCallback: updating dump comment
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20130223181827_1.dmp
Segmentation fault
Add "-debug" to the ./srcds_run command line to generate a debug.log to help with solving this problem
Sat Feb 23 18:18:27 CET 2013: Server restart in 10 seconds



Not sure if you have your post in the right forum, but I’ll respond anyways.

I am also running my server (sandbox build) on Debian 6 and I receive segmentation faults also.

So far the only fix I have is updating the server via:


./steam -command update -game garrysmod -dir . -verify_all

within your srcds root directory.

This will download the “missing” .so files.



  0:50 Updating 'OB Linux Dedicated Server' from version 200 to version 202

  0:59 [208.64.200.9:27030] Reusing connection
  0:59 [208.64.200.9:27030] Sending login message...
  0:59    5.08%  downloading ./orangebox/bin/datacache_srv.so
  0:59    12.95%  downloading ./orangebox/bin/dedicated_srv.so
  0:59    41.16%  downloading ./orangebox/bin/engine_srv.so
  0:59    41.83%  downloading ./orangebox/bin/libsteam_api.so
  0:59    43.56%  downloading ./orangebox/bin/libtier0_srv.so
  0:59    45.99%  downloading ./orangebox/bin/libvstdlib_srv.so
  1:00    60.80%  downloading ./orangebox/bin/materialsystem_srv.so
  1:00    69.91%  downloading ./orangebox/bin/replay_srv.so
  1:00    70.76%  downloading ./orangebox/bin/scenefilecache_srv.so
  1:00    72.17%  downloading ./orangebox/bin/shaderapiempty_srv.so
  1:00    74.11%  downloading ./orangebox/bin/soundemittersystem_srv.so
  1:00    82.33%  downloading ./orangebox/bin/studiorender_srv.so
  1:00    99.94%  downloading ./orangebox/bin/vphysics_srv.so
  1:00    100.00%  downloading ./orangebox/srcds_linux
  1:00 [208.64.200.9:27030] Disconnecting
HLDS installation up to date

After that just start your server normally and it should start fine. Using -autoupdate and -verify_all parameters will not download these “missing” .so files. You need to use the process previously discussed.

Edit

I just did this on my test server and I got a segmentation fault haha… Its how I normally fix my public server.

Did it again now and it worked with my startup line of:



./srcds_run -console -game garrysmod +map freespace06_v2-1.bsp -maxplayers 16 +ip xxx.xxx.xx.xx -port 27045 -autoupdate -verify_all

You know what helped me?
Just don’t put “-autoupdate” in the command line! I mean, without this one I’m getting loads of errors more in console, but I think they don’t mind - cause its just some Steam API Failures wich don’t mind InGame.
But it fixed the Segmentation fault! And If you need to update your game, just update it manually over ./steam

Cause the -autoupdate command is overwriting the bins etc.

And oh yeah, thanks for your reply :slight_smile: