Selfhosting server/FTP on linux, FastDL is being difficult.

Okay.

Lets get the basic right.

I have installed steamCMD and downloaded gmod on my own Kubuntu server.
Have tested and hosted games and they work when I use workshop addons.
I have setup my own FTP server so I could have FastDL (ftp://5.103.162.215/)
The problem comes when I try to get it to load the files on the FTP.
I have watched most videoes on youtube with this problem, googled the problem and read the thread here on FP and no dice.
It’s like when I connect to the game it “downloads” but dont load it into the game.
Right now I have taken this workshop file (https://steamcommunity.com/sharedfiles/filedetails/?id=862401005) and run it through GMAD extractor and loaded the lua folder into addons/-name of addon-/ and loaded the materials, models and sound into my FastDL folder.
I have made a resource file with fox resource generator and have put the file in the autorun/server folder.
Have edited the server.cfg file in cfg so it has

but when I loadup the map and load-in there is just shows errors when I chose a weapon from the addon.
It’s missing the model/texture?(cant tell without model) and the sounds.

I have looked if I have made the wrong file paths or made some casesentive errors but it seams right.
Have tried to fix this error I get when using the weapons

I looked at the lua file for the axe and tried to see if the path was wrong but it seams right.

Would really love a Guide for people with 2 digit IQ because I feel like a spakker for not figuring it out. I have linked the folder I have on my FTP.

You need http server for fastdl not ftp

When i do that it doesn’t download anything and gives me this error for each file in the console.
"HTTP Error 6 Downloading http://5.103.162.215/models/weapons/axe/v_axe.mdl.bz2 " etc.

Enter the URL into your browser and try to download the file. I am sure you will figure out why that doesn’t work.

Because its “http://” and not “ftp://” i can view the file and download it just fine when i put in:
ftp://5.103.162.215/models/weapons/axe/v_axe.mdl.bz2
but i can’t when:
http://5.103.162.215/models/weapons/axe/v_axe.mdl.bz2

GMod needs https links ( a WEB server ), it will not accept ftp links ( FTP server ).