$sequence

I have made a spikestrip and want to compile it with the animation to expand it, the animation is made up of 2 smd files.


$modelname        "termin/spikestrip.mdl"
$body mybody    "spikestrip.smd"
$staticprop
$surfaceprop    "metal"
$cdmaterials    "models/termin/"
$scale            1


$sequence idle    "idle.smd" loop fps 1


$animation l_expand "LAction.smd" subtract idle 0
$animation r_expand "RAction.smd" subtract idle 0


$sequence expand delta {
        l_expand r_expand
}


$collisionmodel    "phymodel.smd" { 
    $automass
    $concave
}


$keyvalues
{
   "prop_data"
   {
       "base"  "Metal.Medium"
   }
}


It errors as a Exception Access Violation (Asset 1) and I know the error is to do with the sequence expand. What am I doing wrong?

(Asset 1) or (Assert 1)?

If it’s assert 1 make sure your .qc and everything are in the correct folders.

Thanks for correcting me it was Assert, all files are in the same folder. When I remove this section it works fine.



$sequence expand delta {
        l_expand r_expand
}


Is there anything wrong with this part?



$sequence expand delta {
        l_expand 
        r_expand
}



Try this, I’m pretty sure they should be on separate lines as they’re two separate .smds and animations.

Still got the same result I’m afraid

Edit: Removing one of the animations works, so I must be laying it out wrong some how

Try removing “subtract idle 0” from one of those $animations, seeing as both would be playing and subtracting “idle” twice.

Didn’t work either, tried removing it from each then with the other suggestion, all give the same error.

Okay I made the animation into one file so the qc looks like this:



$modelname		"termin/spikestrip.mdl"
$body mybody	"spikestrip.smd"
$staticprop
$surfaceprop	"metal"
$cdmaterials	"models/termin/"
$scale			1


$sequence idle	"idle.smd" loop fps 1


$animation expand "anims/Expand.smd" subtract idle 0


$sequence spike_expand delta {
		expand
}


$collisionmodel	"spikestrip.smd" { 
	$automass
	$concave
}


$keyvalues
{
   "prop_data"
   {
       "base"  "Metal.Medium"
   }
}


Anyone know how to make this animate in Gmod?