Serious Problem!

Every single skybox texture I try to use, says this whilst compiling:

This just randomly started happening and now no matter what I try I have no skybox!

Please help!

That’s VBSP expecting an HDR compliant skybox to be used. Shouldn’t be a problem.

Post the entire compile log.

Here:

What exactly is meant by “no skybox”?

There’s no actual skybox texture, it’s all black.

Basically I get the same effect as having no skybox at all.

Happen to be using the Cordon Tool?

Nope…

Missing texture?

I can see the texture in the browse menu, so I don’t see what the problem is.

EDIT: And it’s not just my map, even when I try to create a new one it gives me the same error.

You are using the skybox texture right?

toolsskybox (i believe) for the sky in hammer.

I know, I got that… No skybox textures work and it always says the RT is missing. Everythings been going fine and it’s suddenly started saying this.

Compile with HDR?

Tried, same problem…

Take a picture in game for us.

THERE’S YOUR PROBLEM.

It should be.

Change which texture to use (sky_day01_01rt obviously doesn’t exist) by clicking “Edit” and then “Map properties”
A window that looks like the entity editing should pop up.
Look for an option called “Skybox material” and change the skybox name to one of these.

And make sure you are using the tools/toolsskybox material on the brushes you want to show the sky.

I laughed so hard at the above post for not reading the thread. Have a dumb.

Okay it seems I fixed the problem. Somehow the “Hammer VMF Directory” changed itself and when I changed it back all of a sudden it worked, I’m not sure what the directory has to do with skyboxes though…