Seriously need help random all black textures.

So i was playing Gmod about a month ago and i noticed that some of my textures have turned all black. Mostly they are textures on weapons. I figured it must have been a recent addon or something so i decided to uninstall all of my addons. Then i started the game back up, and the problem was still there. I then tried to delete the game and re install it. That still did not work. Then i thought it could have been an svn, so i unversioned all of my svns. Still no luck. Then i realized that i had installed DOD:S right before this problem arose. I thought surely that must have been the source of the black textures. I un-mounted the DOD:S content from Gmod, and was outraged when still that had not worked.

So now i turn to the Facepunch community. hopefully someone here will have had the same problem and resolved it. Right now I think the only option i have left is to delete every single source game i have, and then re-download them all, as well as all of my GMod addons. Below is a list of various specific info on the problem

COMPUTER:
Toshiba Satellite L455
Windows 7 Professional
Intel Celeron CPU 2.19 Ghz
3.00 gigs DDR3 RAM
250 Gb hard drive with 75 Gb free

GAMES:
Counter Strike: Source
Day of Defeat: Source
Portal
Half Life 2
Half Life 2 Lost Coast
Garry’s Mod

PICTURES OF PROBLEM:
http://yfrog.com/jcgmbuildersworldfinal000j
http://yfrog.com/63gmbuildersworldfinal000j
http://yfrog.com/48gmbuildersworldfinal000j
http://yfrog.com/fxgmsnabbansairfieldb1000j
http://yfrog.com/7hgmsnabbansairfieldb1000uj
http://yfrog.com/05gmsnabbansairfieldb1000j

Validate game files?
What are your current graphic settings on garrysmod?

How do i validate my game files?

CURRENT GRAPHICS SETTINGS:

Resolution: 1280 x 600

ADVANCED:

Model Detail :High
Texture detail: High
Shader detail: High
Water detail: Reflect World
Shadow detail: Low
Color Correction: Disabled
Antialiasing mode: None
Filtering mode: Trilinear
Wait for vertical sync: Disabled
Motion Blur: Disabled
Field of view: 75 degrees
Multicore Rendering: Disabled
High Dynamic Range: None
Hardware DirectX level: DirectX v9.0
Software DirectX level: DirectXv9.0

[editline]5th December 2010[/editline]

Seems even toybox weapons are not safe. tried to use this g18 that was up and got this

http://yfrog.com/mjg18sj

You didn’t list the video card of your computer.

[editline]5th December 2010[/editline]

To validate your game files, right-click the game in your Steam library, go to Properties, and I’m slightly uncertain about this step because I’m on an iPod at the moment. In the properties dialog, I think there’s a tab called Game Files. Under that tab, I’m pretty sure there’s a Validate Game Files button.

I found a “verify game files” but nothing about validating. also here are my graphics card specs

Display Type:
HD TruBrite® LCD Display

Display Resolution:
Supports 720p content, 16:9 aspect ratio, 1366x768 (HD)

Graphics Engine:
Intel® Graphics Media Accelerator 4500M

Graphics Memory:
128MB-1340MB dynamically allocated shared graphics memory

But i really don’t think it has anything to do with my graphics card. I mean i updated my graphics card software but i am pretty sure that was after i started to see the problem.

bumping for great justice.

So what? Are you racist or something?

I have same problem.

Just a hunch… try ‘mat_specular 0’ in your console.

Click the Validate button. It will validate the game files.

I’m having this same problem too, and I also think it’s been going on for about a month. I think it was one of the Garry’s updates that started this.

-dxlevel 90

no luck there

[editline]11th December 2010[/editline]

is that to say its my direct X? it used to work fine on this comp.

[editline]11th December 2010[/editline]

good to know its not just me. Any idea when the next update come out.

Still having this problem, can anyone provide a fix?

It could be your card. Are you sure you’ve never had this problem before? I know intel’s integrated graphics cards aren’t always/usually functional with the source engine.

try -dxlevel 81

Note: your graphics will look like crap but the black spots should be gone.