Server cache issues... Please Help!

Ok so right off the bat I should explain that this is a file permissions problem. I honestly don’t know what the permissions should be for the cache files. Currently the server will not download the cache files and my server gets stuck at “Sending Client Info” til I “Time Out”. It gets stuck at sending client info for me and two of my friends so I know its not just my issue. I will include some pics of my current file permissions. Thanks!

The first picture is the file permissions of the folder. The second picture is the file permissions of the .dua files…

http://img59.imageshack.us/img59/5924/filezilla1.jpg

http://img840.imageshack.us/img840/279/filezilla2.jpg

[editline]18th October 2011[/editline]

Sorry about the poorly done pictures…

[editline]18th October 2011[/editline]

Sorry about the poorly done pictures…

[editline]18th October 2011[/editline]

Actually now I dont think it is a cache issue. I dled the latest cache file from my ftp and put it in my garrysmod/cache folder. Still having the sending client info issue with my server. So what I am thinking is that this is a .dll issue. Maybe the server.dll or client.dll. Do they need to be replaced?

Here are some picures of my client console as I was trying to connect to my server…

http://img94.imageshack.us/img94/5198/console1b.jpg

and the second page:

http://img20.imageshack.us/img20/3361/console2i.jpg

[editline]19th October 2011[/editline]

I’ll try updating my server tomorrow. Hopefully garry fixes this. Seems like something goes wrong every time garry’s mod updates…

Try deleting all your bin folders and re-updating your game server installation with the -verify_all parameter.

All of my bin folders? What other bin folders would I want to delete besides garrysmod/bin?

[editline]19th October 2011[/editline]

Is this where I put the -verify_all parameter? Sorry if this is a stupid question, I never have to mess with this shit on my server.

http://img42.imageshack.us/img42/4310/verifyall.jpg

[editline]19th October 2011[/editline]

The -verify_all command is already in there. I found it…

http://img823.imageshack.us/img823/2659/founditf.jpg

[editline]19th October 2011[/editline]

So What now? I will delete the bin folder in garrysmod/bin and update and see if this works. It normally replaces files missing… It pisses me off the most when I update it and all those fucking gamemodes are in my gamemode folder… RAGE!

I will tell you whether this works or not.

[editline]19th October 2011[/editline]

Nope… Still getting the sending client info issue. This leads me to believe the base gamemode is outdated and needs to be replaced. I’ll delete that and the fretta gamemode folder and tell ya if I have any luck =D! Maybe terrortown is outdated? Ill delete that too!

[editline]19th October 2011[/editline]

Didn’t work. Ok for anyone else who is having this issue I have narrowed it down. Its not a garrymod/bin issue. Not a gamemode issue. Not a Addon issue. And not a cfg issue (However I noticed the only way to change my gamemode was through game.cfg ). So now im thinking its prolly an orangebox/bin issue. So im going to now try and delete everything in there, update, then resstart and see if I have any luck. If not im fucked…

Well the orangebox/bin issue did not work… I guess im screwed… I also found this in my server console when I restarted it after updated:
Compressing lua files into data pack…
Skipped. Datapack exists.
ConVarRef room_type doesn’t point to an existing ConVar
Executing dedicated server config file
Initializing Steam libraries for secure Internet server
Failed to load Steam Service
ServiceStart: failed to start
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit

Hope this can be of help? =D

sv_defaultgamemode should always be in autoexec, not in files that will loop on map changes. And -verify_all is a parameter for HLDSUpdateTool. I use the following batch file to update my server.



cd C:\SERVERS\srcds1
HldsUpdateTool -command update -game garrysmod -dir C:\SERVERS\srcds1 -verify_all
pause

Note that the directories will change for you, you’ll need to make the adjustments for your configuration.

Sorry but BTW, I’m not hosting the server myself, I’m paying someone to host my servers. I access my files with filezilla as you could see in the pictures. And by the way… I have always had my sv_defaultgamemode in server.cfg and its worked just fine for me. Also is it the srcds_run file that I need to edit? /service47/GameServerGM/orangebox/srcds_run… And what do I need to do with this file. I need specifics. I never mess with this shit, have never had problems like this before…

[editline]19th October 2011[/editline]

libtier0.so _gmonstart _Jv_RegisterClasses _fini __gxx_personality_v0 _init libvstdlib.so libm.so.6 libdl.so.2 dlsym dlerror dlopen dlclose libpthread.so.0 __errno_location libc.so.6 getenv putenv getcwd snprintf _IO_stdin_used __libc_start_main strerror puts _edata __bss_start _end GLIBC_2.1 GLIBC_2.0

Found this in my srcds_linux file in my orangebox directory! gmon? Yea right! SHould I change it to gmod? Cuz I dont want to fuck anything up more than it already is? Hope this is the source of my issue…

Figured out that there is something either wrong with the network/server box… So I will have to get in there and do some work.You can delete this post I guess…