Server CFG is inconsistant

I have no idea if I spelt inconisistant right.

So basically the server cfg seems to be a little glitchy and not always run. By this I mean things such as pre round grenade throw sometimes works although it’s off, end of round death match sometimes doesn’t work, etc. As far as I can tell there’s nothing conflicting but I wouldn’t know much. I’ve tried re-doing it, restarting etc to no avail. Any help is appreciated, thanks.


 
//
// garrysmod\cfg\server.cfg
//
// This is the main configuration file for your server.
// See the following URL for more information:
//
// http://maurits.tv/data/garrysmod/wiki/wiki.garrysmod.com/indexebfc.html#Example_Server_Config_File
//
// Changes to this file require a restart.
//
// Last Modified: 23 June 2013  
//

// Server Name
hostname		"Phoenix Gaming | Custom"


// RCON Password (Remote Console Password)
rcon_password		"snip"


// Server Password (Connect Password, "" for nothing)
sv_password		""


// Game Log Settings
log			on
sv_logbans		1
sv_logecho		1
sv_logfile		1 
sv_log_onefile		1


// TTT Commands
"ttt_no_nade_throw_during_prep" "1"
"ttt_karma_low_ban_minutes" "120"
"ttt_postround_dm" "1"
"ttt_karma_low" "750"
"ttt_namechange_kick" "1"
"ttt_detective_hats" "1"
"ttt_haste_minutes_per_death" "0.16"
"ttt_minimum_players" "2"
"ttt_postround_dm" "1"
"ttt_firstpreptime" "35"
"ttt_posttime_seconds" "25"
"ttt_preptime_seconds" "25" 
"ttt_det_credits_starting" "2" 
"ttt_playercolor_mode" "0"


// Fast DL Settings (DO NOT CHANGE!)
net_maxfilesize		30
sv_allowdownload	0	// 0=FastDL Enabled, 1=FastDL_Disabled
sv_allowupload		1	// 0=User uploads disabled, 1=User uploads enabled
sv_downloadurl "http://95.154.240.183/854/Gmod/"


// Loading screen settings
sv_loadingurl "http://www.phoenixgamingforums.com/loading.html" 








// Settings
sv_region		3 // https://developer.valvesoftware.com/wiki/Sv_region
sv_lan			0 // 0=Internet (default), 1=LAN only 
sv_kickerrornum 0


// Dev log option set to 1 to log LUA errors to file
lua_log_sv 1


// Execute Ban Files
exec banned_ip.cfg	// Ban IPs
exec banned_user.cfg	// Ban Users 


The only thing I could think of would be that the cvars are in quotes, it shouldn’t make a difference but that might be why. Avoid putting your rcon in the server.cfg, instead put in your launch parameters as ’ +rcon_password “password” ’ (no ’ 's)

Sorry for the late reply, this cfg works just fine in my vps test server… ;_; slightly confused now.

Try to use the standard server.cfg and add 1 new convar for every start.
And remove http:// from your sv_loadingurl convar.

Ok, that seems logical. However the http:// doesn’t effect anything.

It does though .

Did you try changing stuff like “ttt_no_nade_throw_during_prep” “1” to just ttt_no_nade_throw_during_prep 1 yet?

No not yet, sorry I’ve been getting sidetracked, I’ll do so now.

EDITED
Done as requested, http:// is out (I’m still confused as the loading screen worked everytime but ok) and I will test when I have finished all my work. Thank you all for the help.

No result, sigh. Anymore suggestions? Thanks for all the help soo far.

put some of it in autoexec