Server crash on disconnect

Hello dear Facepunchers,

Whenever somebody disconnects from my server with a special reason (e.g. a Timeout) the server crashes. (So when somebody disconnects by user nothing happens but with for example a timeout it crashes).

I have searched trough all addons etc. but I could not find anything.

Now I have the question if anybody of you has the same problem, or knows a fix.
The current addons are installed and active:

Adv Duplicator
Stargate
Conna’s tool pack
Wire
CSS Realistic Weapons
DoorSTool
HL2 WeaponItem
Jumper v2.5
keypad
keypad cracker
metamod -> Ye I know, but I use them for web scripts such as ban portal and listing.
sourcemod Ye I know, but I use them for web scripts such as ban portal and listing.
PHX
SG-Mod
Smart Cotraint
Smartsnap -> yea I know its actually client only
Stacker Stool
ToolSearch
Weighttool
wire model pack 1

I’d appreciate all the help I can get!

I made a console.log:

Nothing,

L 02/06/2010 - 14:42:38: “[G4L-DM]Milo<3><STEAM_0:0:12569210><>” disconnected (reason “[G4L-DM]Milo timed out”)
And a new restart/mount begins…

Also no erros, anywhere!

So, no results.

Bad file on the server in question?

Try running hldsupdatetool.

Nope, I can’t find anything.

And everything is up to date.
Thanks for the reasponse.

The hldsupdatetool also checks for files that are having a derp time of it. This is basically the equivalent of verifying files in Steam.

Heres the output of the hlds I have access too:

Starting the Steam Update…
Don’t close this window. If you close this window the update will still be executed on the server

Stopping the game server…
Game server has been stopped.
Checking bootstrapper version …
Updating Installation
Checking/Installing ‘Team Fortress 2 Dedicated Server’ version 56

Checking/Installing ‘Base Source Shared Materials’ version 8

Checking/Installing ‘Base Source Shared Models’ version 4

Checking/Installing ‘Base Source Shared Sounds’ version 4

Checking/Installing ‘GarrysMod Content’ version 72

HLDS installation up to date
Starting the game server…
Game server has been started.
The Steam update has completed.
You may close this window.


So everything seems perfectly fine!
Please facepunchers you are my last hope!

Anybody?

I have discovered its one of the addons, because when I disable them all everything goes perfect! Tough I have completely no ideas which one it’s causing it!
Maybe one of you do?

Thanks in advance.

Try Stargate?

Or Metamod or Sourcemod, since hardly ANY GMod server uses them.

Having Metamod and Sourcemod is a definite no-no for a gmod server. I have previous heard that it causes LOTS of issues with the server, even with no addons installed

We have had it running before, and yea Im doubting it too now at the moment, but I make awesome scripts such as remote admin panels and ban portals for them. And it worked before!

Thanks for the replies, you will hear of me!

[editline]05:49PM[/editline]

UPDATE: It apperantly also crashes on a disconnect.

[editline]06:09PM[/editline]

Fixed, it was Metamod/Sourcemod indeed, tough we havent had this on the previous server.

I have the same problem. Any fixes other that removing Soucemod/Metamod?

Im still looking for that, please send me a PM with your steam details, so i can add you.

Sent.