Server crash upon startup.

Hey all.

So I’ve been having this bug since I reinstalled the server’s OS (Yes, I grabbed ia32-libs and libstdc++6:i386) to Debian 7 x64. I start the server…and then:


Auto detecting CPU
Using default binary: ./srcds_linux
Enabling debug mode

Console initialized.
ConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "Garry's Mod"
Setting breakpad minidump AppID = 4000
Initializing Steam libraries for secure Internet server
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Segmentation fault (core dumped)
BFD: Warning: /home/argh/garrysmod/core is truncated: expected core file size >= 233848832, found: 1236992.
Cannot access memory at address 0xf77868f8
Cannot access memory at address 0xf77868f4
debug.cmds:1: Error in sourced command file:
Cannot access memory at address 0xffd3f2d4
email debug.log to linux@valvesoftware.com
Mon May 12 13:50:20 PDT 2014: Server Quit

debug.log:



----------------------------------------------
CRASH: Mon May 12 13:48:18 PDT 2014
Start Line: ./srcds_linux -debug -norestart -nobreakpad -console -game garrysmod +map gm_flatgrass_airport +maxplayers 8 +sv_password [redacted] +gamemode sandbox -authkey [redacted] +host_workshop_collection [redacted]
[New LWP 20387]
[New LWP 20391]
[New LWP 20388]
[New LWP 20392]
[New LWP 20390]
[New LWP 20393]
[New LWP 20389]
#0  0xea2c627a in ?? ()
End of Source crash report
----------------------------------------------


(repeated about 15 times since I tried a bunch of stuff and it still did nothing)

Here’s my start script; look to line 178 for the server’s command line.

Here’s what I’ve tried:

  • Upon restart the script verifies the entire install, and I’ve manually verified it two or three times.
  • Complete reinstall of the game and SteamCMD, after which the server worked once or twice, I restarted it a couple times, and then it started doing this again.
  • Restarting it repeatedly because I have nothing better to do

There’s several errors there, the first one being that the SteamAPI_IsSteamRunning failed, the later errors such as not being able to find the memory address I’m assuming branch off the first error, but it could be a completely separate problem related to 32 bit/64 bit stuff (which could also cause memory errors)