Server Crashing Map Cleanup - TTT

So I have been hosting servers on GMOD since July. I have also been having constant crashes that I still can not figure out.

I host TTT/Terrortown Servers and the server crashes during round restarts and more specifically game.CleanUpMap.

I have removed absolutely everything from my server, reinstalled, etc. While on gm_construct the server seems to run perfectly fine but when I change the map to any other map it seems to constantly crash. I have tried almost everything I can to fix it but it seems as if I have no hope.

I am hoping someone may know how to fix this issue.

Possible Related issues:
https://github.com/Facepunch/garrysmod-issues/issues/3327

1 Like

TTT Gamemode:
https://github.com/Facepunch/garrysmod/tree/master/garrysmod/gamemodes/terrortown

Maps I have tried:
https://steamcommunity.com/sharedfiles/filedetails/?id=159321088

1 Like

Maps Continued:
https://steamcommunity.com/sharedfiles/filedetails/?id=186842624
https://steamcommunity.com/sharedfiles/filedetails/?id=281454209

1 Like

I think the issue related to yours is this one: https://github.com/Facepunch/garrysmod-issues/issues/3637 (a workaround is on the wiki for this function).

You can also answer on the github by saying that you also had this problem (if possible including a crashdump and steps to reproduce this crash).

1 Like

I have tried this on my server with no luck. I believe I implemented it correctly. I just changed every instance calling game.CleanUpMap with game.CleanUpMap(false, {"env_fire", "entityflame", "_firesmoke"}) Unless I did this incorrectly it didn’t seem to fix the issue.

1 Like

If you have a crashdump, you can always try to send it to Rubat so he can see where the issue comes from: robotboy655@facepunchstudios.com. Don’t forget to specify the server branch (x86-64, dev, etc.).

But before doing that, try to remove the addons from the server (except of course the gamemode) and try if the crash is still present. If the case is no longer there, don’t send the crashdump and try to find the source of the issue in your addons.

1 Like

As I stated above “I have removed absolutely everything from my server, reinstalled, etc.” the issue would not be the addons. However, I will contact him. Thank you.

1 Like

Well, It seems as if I was unable to get any assistance to fix the issue. However, he was able to bring me to this statement

"The picture you sent (https://i.imgur.com/28yW2HA.png) indicates it’s a problem with the physics engine

I can say that it’s a problem with cleaning up SWEP physics object, perhaps the game mode is doing something strange with weapon physics objects?"

1 Like

I would like to help you more but I have no idea, I have never used the TTT gamemode personally. Maybe, you can ask on Garry’s Mod Discord?

1 Like

Which host are you using can also be a usefull information

1 Like

I have used GMC and NFO.

1 Like