Server Cycles Continuously

Hi, I’m making a darkrp server ( >:l ) and when I start it srcds launches the server, and then in the command prompt it says that all of the props were removed and then restarts.

here is my server.cfg


 // Server.cfg Executes on maploads
// For Convars like sv_cheats 1 = on 0 = off
hostport 27015 //Port used for the Server
Hostname “Durza's Playhouse: DarkRP”    // host name
rcon_password “server”    // rcon password
sv_password “” //Server Password. Leave like this for no password.
//Voice Chat
sv_voiceenable 1 // Enable Voice
sv_alltalk 1 // Allow all the teams to talk to each other
// Lan
sv_lan 0 // Lol Lan
//Rates… Change the maxrate according to the tutorial. (Replace the xxx //with a number… lol
sv_scriptenforcer "0"
sv_maxcmdrate 33
sv_maxupdaterate 100
sv_maxrate 25000
sv_minrate 0
sv_minupdaterate 20
//Fall Damage, 1 for realistic, 0 for 10 hp
mp_falldamage 1
//How fast a Spray can be Sprayed, In seconds
decalfrequency 3
// LOGGING
sv_logbans 1
sv_stats 1
log 1 //Turn this off if you don’t like the logging in the console (L <date> then some other stuff), logs are in garrysmod/logs
//Leave off unless you want them on. (Most things that crash servers are cheats.)
sv_cheats 0
//Downloading
sv_allowdownload 1
sv_allowupload 1
net_maxfilesize 64
sv_region 0
sv_timeout 65
//Make sure the Bans are loaded
exec banned_user.cfg
//Sandbox Command Config. Sets the limit of various things. You can //change it to fit your server.
"sbox_maxprops" "15"	 // Don't make this too much if you use a good map as rp_downtown_v2 \\ 
"sbox_maxragdolls" "0"	 // Unnecessary on DarkRP.. \\
// It's disabled so make it 0 \\
"sbox_maxballoons" "2"	 // Balloons  \\
"sbox_maxeffects" "0"	 // Put this off or people will make the skybox weird and dark... \\
"sbox_maxdynamite" "0"	 // It's RP not Oh snap trap, land \\
"sbox_maxlamps" "0"	 // Lamps, this will make the server lagg \\
"sbox_maxthrusters" "5"	 // Why would we need thrusters anyway? \\
"sbox_maxwheels" "4"	 // Idk if roleplayers are bored... \\
"sbox_maxhoverballs" "0"	 // This will only be prop lifting \\
"sbox_maxvehicles" "0"	 // You can spawn vechicles not recommended on small maps \\
"sbox_maxbuttons"	 "5"	 // Just make it enough, people want to have buttons or its prop block \\
"sbox_noclip" "1"	 // Everyone will be able to noclip also guests. \\
"sbox_godmode" "0"	 // Godmode; no one will be able to die in your server. \\ 
"sbox_plpldamage" "0"	 // PeopleDamage; 1 = Disabled 0 = Damage; deathmatching \\ 

ulx map rp_downtown_v2 DarkRP
//End 


The server.cfg is loaded after the map is loaded. At the end you have “ulx map rp_downtown_v2 DarkRP”, so after the map loads, it executes that, again. Creating a cycle.

Here is server startup code if it helps:


 @echo off
cls
echo Protecting srcds from crashes…
echo If you want to close srcds and this script, close the srcds window and type Y depending on your language followed by Enter.
title srcds.com Watchdog
:srcds
echo (%time%) srcds started.
start /wait orangebox\srcds.exe -console -nocrashdialog -nohltv -game garrysmod -port 27015 +clientport 27005 +hostport 27015 +tv_port 27020 +ip “24.62.144.15” -maxplayers 12 +map rp_downtown_v2
echo (%time%) WARNING: srcds closed or crashed, restarting.
goto srcds 


[editline]2nd January 2011[/editline]

so I need to place ulx map rp_… at the beginning of the config file?

No, you need to set the command line to set the map, not the config.

do you know how I get the command line to set the game mode? That’s what I’ve been having the problem with. I’ve tried sv_gamemode “Darkrp” but it doesn’t load darkrp

[editline]2nd January 2011[/editline]

Sv_gamemode in the config file, that is.

Example: -console -nocrashdialog -game garrysmod +ip 69.197.189.125 -port 27015 +maxplayers 22 +fps_max 128 +map ttt_nexus +exec server.cfg +sv_defaultgamemode 7NNJGTTT7

That should do it. thanks!