Server Downloads stopped working

A server I help run has stopped sending files to players.
I only found out recently that this is happening due to adding new maps to the server, then when I went on to test them they wouldn’t download. They show that they are trying to download but then give the missing map error. I tried other maps that previously worked and they also do the same thing. I checked the location of the files on both FastDL and server and I made sure that no one had changed the FastDL url in the cfg but everything is fine.
It also is happening for models and materials.

I don’t know where to begin looking other than the things I already checked.

Thanks in advance.

Did you pack them in .bz2’s?

Yeah, it’s worked fine for a couple months till some time recently as I said I only found out due to adding new stuff.

[editline]20th December 2013[/editline]

Also these files have been used on 3 other servers that I also help maintain and they all work fine in there current state. No changes have been made to any of the files between servers. Yet only one server has downloading issues.

Post that server’s server.cfg and resources.lua files.



// Make sure the right people are banned
exec banned.cfg
exec banned_user.cfg

// Name Of Server
//hostname "Offline! Fixing MASSIVE Problem."
hostname "[GCN] PineappleGaming! TTT | FAST DL | 1 Hit-Knife"

// General HL Cvars
mp_fraglimit 0
mp_footsteps 1
mp_flashlight 1
//sv_contact "your@email.address"
//sv_loadingurl ""
sv_downloadurl "http://cubedgaming.site.nfoservers.com/gmoddl"
decalfrequency 60
mp_decals 100
mp_falldamage 1
sv_cheats 0
sv_maxrate 0
sv_minrate 100000
sv_maxupdaterate 99
sv_maxcmdrate 99
sv_timeout 120
sv_allowupload 1
sv_allowdownload 1
sv_kickerrornum 0
ttt_minimum_players 2
ttt_playercolor_mode 0
ttt_posttime_seconds 30
ttt_postround_dm "1"
ttt_round_limit 15
ttt_zedtime_enable 1
ttt_zedtime_endround 1
ttt_zedtime_duration 1.2
ttt_zedtime_detective 0
ttt_zedtime_detective_loadout 0
ttt_zedtime_traitor 1
ttt_zedtime_traitor_loadout 0
sv_alltalk 0
utime_welcome 0

//files
mapcyclefile mapcycle.txt

// disable lag compensation
//sv_unlag 1

heartbeat

// important settings inserted by NFo
sv_stats 0
sv_region 0
fps_max 0

sv_parallel_packentities 0
sv_parallel_sendsnapshot 0
net_queued_packet_thread 1
net_splitpacket_maxrate 100000

writeid
mp_timelimit 999
log 1
tv_enable 0
sv_password ""

I don’t resource lua the maps I just have ULX force the maps folder and the resource for other models and things I have work on the other servers.

http://cubedgaming.site.nfoservers.com/gmoddl is not a valid site. Check for yourself.

Then how can I be connecting via FTP?

[editline]20th December 2013[/editline]

Ok, I have found the problem it appears someone at somepoint decided they would go into the servers control panel and change the subdomain hence the invalid site. I should have everything worked out soon.

It’s back up, never mind. Your FastDL looks fine.

Yeah it’s back because I changed the sub domain back to it’s original name for now.