Server fails to start after deciding it's port


Pretty new here, and just looking for help. Please be kind D:

So I’m running a dedicated server using Ubuntu 14.04.5 LTS with some pretty standard iptables.
My current iptables are:

iptables -I INPUT -p tcp --dport 27005:27019 -j ACCEPT
iptables -I INPUT -p udp --dport 27005:27019 -j ACCEPT
iptables -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
iptables -I INPUT -p tcp --dport 22 -j ACCEPT
iptables -I INPUT 5 -i eth0 -p tcp --dport 80 -m state --state NEW,ESTABLISHED -j ACCEPT
iptables -A INPUT -j REJECT

Pretty much, I’ll start up my ttt server on 27015 and it starts fine. I’ll start up darkrp on 27016 and it’ll go all the way up until it decides which ports and also goes to 27020 which is weird.

steam@server:~/darkrp$ ./srcds_run -game garrysmod +gamemode darkrp
WARNING: No map specified! Server may not heartbeat.
Auto detecting CPU
Using default binary: ./srcds_linux
Server will auto-restart if there is a crash.
FIND [/home/steam/cssds/cstrike/*.vpk]
ADDING [/home/steam/cssds/cstrike/cstrike_pak_000.vpk]
Adding Path: [/home/steam/cssds/cstrike]
Couldn't load shader dll: game_shader_generic_garrysmod_srv.soConVarRef mat_dxlevel doesn't point to an existing ConVar loaded for "Garry's Mod"
Setting breakpad minidump AppID = 4000
Initializing Steam libraries for Workshop..
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Fetching Workshop Addons.. No -authkey
Adding Filesystem Addon '/home/steam/darkrp/garrysmod/addons/2d3d textscreen'
****skipping the obligatory addon list****
Adding Filesystem Addon '/home/steam/darkrp/garrysmod/addons/wiremod'
Unknown command "cl_cmdrate"
Unknown command "cl_updaterate"
Unknown command "rate"
Changing gamemode to DarkRP (darkrp)
WARNING: Port 27015 was unavailable - bound to port 27016 instead
WARNING: Port 27005 was unavailable - bound to port 27006 instead
WARNING: Port 27020 was unavailable - bound to port 27021 instead
Network: IP NOPE, mode MP, dedicated Yes, ports 27016 SV / 27006 CL

If I close TTT and start DRP it wont do the port shuffle “bound to port… instead” it will just say:

Network: IP NOPE, mode MP, dedicated Yes, ports 27016 SV / 27006 CL

I used to use the autoexec file to have most of the switches in there, and just start with -game garrysmod and +gamemode darkrp
It would set the map, port, playercount, all the other stuff. Now that is empty and I just can’t get past this. I’ve tried to set it to sandbox or terror town but doesn’t want to happen :confused:

Send halp!

Use my guide on setting up it up properly.

Go step by step, make sure you don’t miss anything.

Through that link I provided another link of the full tutorial