Server FastDL Issue

Hi.

Firstly - I know that the category is for problems PLAYING the game, but I really don’t know where else to turn as I’ve tried everything.

I’m trying to set up FastDL for my Garry’s Mod server. Currently, when people try to connect to cs_office on the server who don’t have the map, they’ll be given a MISSING MAP error instead of downloading it via the system. Both the server and the files for FastDL are hosted on the same dedicated server, and the files can be accessed at mydomain.com/fastdl/garrysmod/. Currently, in the garrysmod folder for my FastDL, there is only one folder which I have manually set up called maps which has clue.bsp.bz2 and cs_office.bsp.bz2 - compiled using bzip2 - based off many tutorials I’ve watched and read.

I also read something about having a cache folder which is ‘mandatory’ for FastDL to work, in which I should use the cache file generated by the game in /garrysmode/cache and copy it over. However, this directory does not exist and I cannot find a cache file anywhere so I’m unsure what I should do in regards to that. I also tried using .bsp files in the /fastdl/ folder but that didn’t work either.

I’ve experimented with having allow_download on both “1” and “0” but neither seem to be working correctly.

If anybody has any solutions for this, please let me know and I’ll be extremely grateful.

Best Regards,
Rees.

Can you please post your actual URL?

Sure, it’s http://213.251.187.50/fastdl/.

Your FastDL directory should mirror garrysmod, meaning the sv_downloadurl should be http://213.251.187.50/fastdl/garrysmod/

Thank you for the response.

The sv_downloadurl was already:

but people still have the ‘no map’ error. I’m unsure what could be causing this.

Unless they were compiled into .bz2’s incorrectly, I’m stumped.

Have you tried resource.AddFile on the map?
It may not be forcing the client to download it.
That’s the only thing I can think of at the moment.

Thank you for the response.

Is resource.AddFile necessary for a map? I thought it was solely for materials, etc.
If so, how would I go about adding this?

Best Regards.

lua/autorun/server

Make a lua file there.

Add in there this


resource.AddFile("maps/cs_office.bsp")

Hope this works,
-JK

Thank you once again for the support.

I’ve made a file (titled it anything, wasn’t sure if it needed to be specific) and pasted in what you recommended.
I assume I’d need to restart the server for this to take effect [as the person testing still cannot get on at this stage], but was firstly wondering whether the file extension is correct as .bsp or whether it has to have the extension .bsp.bz2?

Best Regards.

Sorry, yes it would be whatever extension you have there.

You NEVER resource.AddFile maps.

I tried anyway for good measure, but it did not work.
Is there anything else you would recommend?

Best Regards.

On your client,


clear;download_debug 1

then join your server and look in the console for errors

Thank you for the reply.
Here’s some of the interesting things I got:

The rest of it is just styled like this: TEST [lua/autorun/addcarhornstolist.lua][lua/autorun/workshop.lua]
and just a few fonts that could not be downloaded.

Any ideas?

Best Regards.

You may have to set


developer 4

and rejoin

Thank you once again for helping to troubleshoot the issue. Here is what I got this time:

After running “developer 4” in console.
Any ideas?

Best Regards.

PM me your server IP

Looking at your original errors:

  1. Post your workshop.lua file. I have a feeling your missing an end.
    2+3. Not an issue
  2. Those are displayed after lua errors.

Thanks for the response.

I initially tried using the Workshop content instead of FastDL, but I ended up scrapping the idea. I forgot to delete the file and - after seeing the message - have done so (the server just needs a restart).