Server gamemode problem

I made a Garry’s Mod 13 Sandbox server and want to make a Garry’s Mod 13 DarkRP server. I have everything installed but the gamemode won’t change. I have a server_startup.bat file to start the server and this is what the file looks like:

@echo off
cd c:\GameServers\GMOD13ServerDarkRP\orangebox
echo Starting game server.
echo Starting “Raven Gaming Garry’s Mod Server”
srcds.exe -console -game garrysmodbeta -port 27011 +sv_defaultgamemode DarkRP +map gm_construct +maxplayers 24 -ip 193.33.186.228 -tickrate 100
echo “Raven Gaming Garry’s Mod Server” has now started.
echo It is recommended that you start Server Crash Recovery aswell.

I get this error in the console of the server startup and it loads to Sandbox.

Unknown command "sv_defaultgamemode"

I also put these commands in the server.cfg file and they showed as errors too.

sv_defaultgamemode “DarkRP”
sv_gamemodeoverride "DarkRP"

Any ideas on how to fix it?

Probaly because garry chose to remove the commands in gmod 13? I have however no idea what the new commands is as i dont have gmod 13 beta myself.

Also, i dont even think darkRP is compitable with gmod 13, and if it is there might be quite a few bugs wich need fix, my recommendation is at least to wait for the DarkRP team to launch a official release for gmod 13 instead as this is far from optimal if even possible.

DarkRP is currently in beta testing and I would love to test it.
http://facepunch.com/threads/1176387

This is because DarkRP is still in beta testing and gmod 13 is as well.
I heard they are doing pretty great so far so I’m excited myself.
Be patient until they release it, and don’t use
The regular DarkRP gamemode on Gmod 13

Well, currently I’m trying to use the beta version of the DarkRP.
I’m not sure what the problem is.

try autoexec.cfg file and put"sv_defaultgmode “darkrp”

in there

I know to use that. I don’t think it would work though but I’ll give it a shot.

Sigh, by reading your post i thought you allready did used the search machine called “google”, no clue if you ever heard of it? anyways, next time, try it out! its cool and find pretty much everything important!

anyways, since ur lazy, here: http://facepunch.com/threads/1175947

EDIT: next time dont double post your thread when this one is number 1-3 allready please, if this topic was on page 10001 i could understand a double post, but seriusly? it was number 2 when i looked in the forum.

its just gamemode “gamemodehere” now

Nothing seems to work I’ve been through all the threads trying each and every cmd for each and every gamemode and still it has no effect… looks like I just wasted a heap of my cash on a barely existent server…

[editline]6th October 2012[/editline]

:suicide:

put “gamemode” “DarkRP” in the server.cfg

worked for me

Last time someone had this problem(several times actually)
It was because they wrote it as DarkRP , and it needed to be darkrp.