Server Infinite Loop

Hello. My friend has a problem with his server.
He just bought a 40 slot gameserver, and we’re trying to start with DarkRP gamemode, The problem is when we start with DarkRP gamemode, it gets into an Infinite Loop, Restarts over and over again. When we tried sandbox gamemode, it didn’t loop.

Heres the server.cfg:


"hostname"                "Name"
"rcon_password"                 "--------" 
"sv_password"                 "----------"
"sv_region"                     "255" // eastcoast: 0 - westcoast: 1 - south america: 2 - europe: 3 - asia: 4 - australia: 5 - middle east: 6 - africa: 7 - world: 255
"sv_lan"                    "0"
"sv_defaultgamemode"              "DarkRP"

// Sandbox server settings
"sbox_allownpcs"                "1"
"sbox_godmode"                "0"
"sbox_plpldamage"            "0"  // set this to 1 to disable player vs player damage.
"sbox_playergod"                "0"
"sbox_noclip"                "1"

// Sandbox limits
"sbox_maxprops"                "30"
"sbox_maxragdolls"            "5"
"sbox_maxnpcs"                "10"
"sbox_maxballoons"            "10"
"sbox_maxeffects"            "50"
"sbox_maxdynamite"            "10"
"sbox_maxlamps"                "20"
"sbox_maxthrusters"            "30"
"sbox_maxwheels"            "20"
"sbox_maxhoverballs"            "20"
"sbox_maxvehicles"            "6"
"sbox_maxbuttons"            "20"
"sbox_maxsents"                "20"
"sbox_maxemitters"            "5"
"sbox_maxspawners"            "3"
"sbox_maxturrets"            "2"


//DarkRP
net_maxfilesize 50
sbox_noclip 0
sbox_plpldamage 1
sbox_godmode 0
ulx map RP_DownTown_V2 DarkRP
rp_showjob 1
rp_toolgun 1
rp_proppaying 1
rp_letters 1
rp_earthquakes 1
rp_maxcps 5
rp_drugpayamount 30
rp_maxdruglabs 4
rp_maxgangsters 5
rp_maxgundealers 2
rp_allowpdchief 1
rp_dm_autokick 0
sbox_noclip "0"
sbox_godmode "0"
sbox_plpldamage "0"
rp_toolgun "1"

//Voice chat
"sv_voiceenable" "1" 
"sv_alltalk" "0"


//Fall Damage, 1 for realistic, 0 for 10 hp
"mp_falldamage" "1"



// LOGGING
"sv_logbans" "1"
"sv_stats" "1"
log 1 //Turn this off if you don't like the logging in the console (L <date> then some other stuff), logs are in garrysmod/logs

//Rates (Don't change unless you under stand these)
sv_maxcmdrate 33
sv_maxupdaterate 60
sv_maxrate 0
sv_minrate 2000
sv_minupdaterate 20


//Downloading
"sv_downloadurl" "http://a4p.host-right.info/orangebox/garrysmod"
"sv_allowdownload" "1"
"sv_allowupload" "1"
"net_maxfilesize" "100" //Holy shit, a command no one ever uses


//Make sure the Bans are loaded
"exec banned_user.cfg"

So any of you guys out there know what’s causing this, or any suggestions what might be causing it?

Remove “ulx map RP_DownTown_V2 DarkRP” from your server.cfg - the server.cfg get’s executed everytime the map sucessfully started up, therefore it’s causing your map to restart over and over again - Edit the Command-line arguments or take a look into the Webinterface to change the default map.

net_maxfilesize is also repeated twice with varyed values.

Okay, thanks. Problem solved.