Server Install Issue on Linux

Hello Community,

I am trying to install a Gmod Server on my rootserver throught PuTTy right now. I use this tutorial: http://wiki.garrysmod.com/page/Linux_Dedicated_Server_Hosting
I always get the following error with the following command:


kilian@Ubuntu-1204-precise-64-minimal:~/bin$ ./steamcmd.sh +login anonymous +quit
./steamcmd.sh: line 29: /home/kilian/bin/linux32/steamcmd: No such file or directory


I can’t figure out what the problem is. Right now I am not using the root user, but I already tried it with it. I am not a linux expert so please be patient.

Greetings Tezou

At what point do you get this error? The error is saying that something is missing, so maybe you missed something

At this point the error show up:

Are you sure the tar command worked correctly? It seems it didn’t extract the files

Yeah I’m sure It worked. I see the files extracting and they also show up in the directory.

Can you check “/home/kilian/bin/linux32/steamcmd” exists? If it’s in a slightly different directory you may have to change the sh script

Yes it does.

Could the problem be, that I don’t have steam installed on the rootserver?

I’m not fully sure, you can try posting this in the linux forum, someone there is bound to know

What forum exactly do you recommend?

http://forum.facepunch.com/showthread.php?t=1250227

Try asking here