Server is in lan mode

Hello,
I have a problem with the newest gmod update. Today I updated my server and now it is starting in LAN mode.


Initializing Steam libraries for secure Internet server
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
SteamGameServer_InitSafe failed!
*********************************************************
*********************************************************
*       Unable to load Steam support library.*
*       Unable to load Steam support library.*
*       This server will operate in LAN mode only.*
*       This server will operate in LAN mode only.*
*********************************************************
*********************************************************

What can I do?

Maksimo007

Also happening to me. Server screwed up.

RIP Servers for a bit

Are you on a Linux server?

Yep. Lasted update broke our server :stuck_out_tongue:

Yes, it’s linux^^

Happened in Windows (2012 R2) too.

Windows Server 2012 here too.

Edit: Reinstalling SteamCMD didnt help

Just sit back and wait it out

Someone has fucked up the servers. What the fuck happen with the garrys mod team…

[editline]11th August 2015[/editline]

A virgin server without addons dont work. This is weird. WTF GARRY

Not their fault, they probably didn’t have a big enough testing environment to iron this sort of sh*t out. It’ll probably be hotfixed in the next few hours

It happened to me, but only on one server, the other worked fine, i copied all the dll present in workingserver/bin and i pasted them into notworkingserver/bin and its working again

My servers are effected too. One is on Windows server, the other two are Linux.

Same problem with my servers only thing to do is wait.

To start server you have to use old binaries taken from server that has not been updated.
It worked for me. :joy:

And this is safe?

Copy linux32 binaries from steamcmd to your gmod server/bin

Fixed it for me.

^ Fix for Linux.

Same routine, fix for Windows

Windows Temp Fix
Open SteamCMD and copy the DLL files.
http://puu.sh/jxt8h/ed7ff711d6.png
Paste them in the bin folder on your server.
http://puu.sh/jxt9J/65cf128be8.png

Restart the server, it should boot up. If you update again and the fix hasn’t been issued then you will need to repeat the above.

What libraries i have to more? on steamcmd i just have libstdc++.so.6