Server joining disconnection

It started happening after the recent update, I’m starting Gmod and trying to connect a friend’s server.

The loading screen appears as normally, it’s all fine. I choosed to NOT download any files when connecting to a server. When being at “Sending Client Info” for a while, the loading stops with a message popping up that says:

Disconnected: Timed out

I have a look in the console and I see this:
Sending 1227 ‘User Info’ ConVars to server (cl_spewuserinfoconvars to see)
Disconnect: Deddej timed out.
Disconnect: Deddej timed out.

I tried choosing to download all files and reconnecting to the server, same error appears.

I exit Gmod and defrag the game, verify game cache files, starting it up again, and appereantly the entire screen is black, I find my way to the console without seeing anything and I type in “Connect (server IP)”
The screen is still black but it started to connect to the server.
Whoop! 5 minutes later I connected to the server, spawned, and nothing is wrong.
Then I say something in the chat, and no message appears, but my friend could see it, aswell as the other players. I couldn’t see my message or their messages. But then I can’t even open up the spawnmenu. Holding Q and nothing happens.
I disconnect from the server and I got my screen back. (This screen was only black in Gmod. I run Gmod at 1280x720 boxed mode with a 1680x1050 monitor, so I always see my desktop in the background.)

But then of course I need to allow “Download all files from server”, I connect to the server again. Gets freezed in “Sending Client Info” for a bit, then once again:

Sending 1227 ‘User Info’ ConVars to server (cl_spewuserinfoconvars to see)
Disconnect: Deddej timed out.
Disconnect: Deddej timed out.

This never happened to me before the recent update.

Need serious help

-Thanks.

Doesn’t look like nobody is interested in helping me.

Might be something wrong with your video card or processor. Run some tests to see if they’re working correctly under pressure. Something similar was happening to me as well, turned out my graphics card completely gave up on me. Reinstall or update your drivers, sometimes it’s the simplest things. If not just reinstall Garry’s Mod and only keep a certain amount of addons. Having a lot of addons can cause problems.

Good luck, sorry if none of my suggestions work.