Server kicks people and crash after today's update.

When I start my server there’s no error but when someone tries to connect it shoots this


Dropped Cookies from server (ProcessUsercmds: Incorrect reading frame (check sending and receiving code for mismatches)!

And after two attemps the server just crashes.

Any ideas?

The joiners are using an out of date version. This should clear itself up - it sucks that it’s crashing though - I should have changed the data tables so they couldn’t join at all.

We fixed the crashing problem by doing a verify_all but now the server just crashes every 2 minutes. Any way we could toss you some crash dumps and figure out what might be causing this?

EDIT: Nvm, It’s not giving me crashdumps, it’s just shutting the server down (I think)

Can’t get it to work, it crashes after 3-5 minutes even when there’s no one in the server. I’ve tried using a standard gamemode (aka Sandbox) and the problem still persists.

It worked fine yesterday before the update.

This is seriously killing me, the server stops after 5 minutes, no matter what. There’s no crash dumps, no errors whatsoever.

How the hell do I debug something like that?