Server Map Download Issue

Hello there.

We appear to be having a problem that we cannot seem to solve on our Black Mesa Roleplay server at ALG (109.70.148.13:27018)

Whenever anyone attempts to connect to the server, the client gets a copy of the latest map - rp_lambdacore_beta3fix1 via FastDL.

Trouble is, approximately half way through download, all clients attempting to download the map receive the following error:

Your map (maps/rp_lambdacore_beta3fix1) differs from the servers.

We cannot for the life in us figure out what is causing this issue, because before this, the older versions of the maps work fine without fault.

However, the map also doesn’t show in the singleplayer map list, but launching the map via console works fine singleplayer.

Things we have tried:

  • Re-compiling and re-loading the server
  • checking map name for case-sensitivity and spelling
  • rolling back the map to the previous (works fine, so it seems to be a map issue).
  • clients deleting the map completely and redownloading
  • verifying Game cache

I don’t see how it can differ from the server seeing as it’s the first time downloading and is also off the server. I have also tried compiling it myself - shows up in single player, no luck connecting to server or hosting my compiled version of the map.

The only things we have changed since this map and the older one is changing the HUD layout a bit and making the map un-decompilable.

Any advice is appreciated.

Thanks in advance.

Afterwars

Have you tried re uploading the map to your web server? It may not have uploaded correctly therefore became corrupted.

Hi, thanks for replying.

We have tried that, but to no avail, still the same issue unfortunately.

What happens when a client/player downloads the map out of game and puts it into their maps folder and joins the server?

Unfortunately, the same issue still occurs.

EDIT: We have found out it is a map issue - a certain part in the map was messing about for some reason, but it’s sorted now.

Many thanks anyway.

Afterwars

this is what u do, go into maps and delete the map file that was supplied by the server. then go to garrysmod.org and find the map u need. download that map and then put into maps(i normally put it into toy box maps, i think it works either way). reload garysmod and open the server, hopefully u should join with the working map!!!:rock:

Hi there, the map we created for the server was a custom made one for the server that I and someone else made, we didn’t upload the map to Garrysmod.org or Toybox.

Also, we managed to sort the map out, it was an issue with just too many buttons and sounds on the map, which was causing it all not to compile correctly and work Multiplayer.

Cheers anyway.

Afterwars

oh, i thought u couldn’t crc map on a public server