server menu wont work?

hey i recently just brought rust today and everything is fine untill i get to the main menu when it says choose a server for some reason the server wont load up or get close when i click it, what am i doing wrong please?

Perhaps you are not allowing the server menu to complete the scan of all the servers. Usually it can take between 1-5 minutes to complete the search.

You can usually connect to a server via your console however. For example, press F1 with the game pulled up. From there you can paste the following example to connect yourself to a server:
net.connect 192.169.82.174:28015

Best luck.

thanks that server completely helped just 1 more issue and thats the graphics are laggy

As for that, mind posting your specs?

checked my windows performance my graphics are lowest at 3.4 everything else is in high 5s

That doesn’t really tell me much… I am asking basically what is inside your machine? What is the CPU, how much memory, what graphics?

1g of memory dual core processor dont know rest sorry

It looks like your PC is not strong enough man.

Uh, 1 gigabyte of RAM? You sure that isn’t Video RAM? If so, that is WAY under what would be considered recommended.

I would see this thread for some optimization tips accomplished through more F1 console magic:
http://forum.facepunch.com/showthread.php?t=1372236

helped but still pretty slow movement its not good

Please post your system information based on the system information output of this tool: http://support.microsoft.com/kb/190900

That should help everyone understand your hardware situation, and better assist you. :slight_smile:

Time of this report: 3/4/2014, 23:29:59
Machine name: SEAN-PC
Operating System: Windows 7 Home Premium 32-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130828-1532)
Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
System Model: Latitude D630
BIOS: Phoenix ROM BIOS PLUS Version 1.10 A15
Processor: Intel® Core™2 Duo CPU T7250 @ 2.00GHz (2 CPUs), ~2.0GHz
Memory: 2048MB RAM
Available OS Memory: 2038MB RAM
Page File: 1961MB used, 2118MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode

You need an upgrade. Laptops are not really considered gaming rigs, and your Latitude D630 will not handle modern games very well due to the hardware constraints.

A few things to note here:

You’re maxed out on RAM usage. Try closing some more background applications, or check http://support.microsoft.com/kb/310560 to see what programs are launching during start-up and eliminate any NON MICROSOFT programs you do not want starting, and taking up additional machine resources.

This is mediocre at best, and you should consider having 4 cores @ ~2.4GHz minimum for a modern gaming rig.

As for your GFX card, I’m assuming it’s an “Intel Integrated Graphics Media Accelerator X3100” based on the specs over at http://www.cnet.com/laptops/dell-latitude-d630/4507-3121_7-32445398.html

I have no idea the clock speed of the integrated GPU, but the 256.0 MB video memory is bad. You should aim for at least 1GB of video memory.

One of the best DIY system builders resources I’ve seen is Reddit’s http://www.reddit.com/r/BuildaPC
I strongly suggest you check it out if you want to move forward as a PC gamer on a budget.

Good luck. :slight_smile: