'Server must update to most recent version'

Posting this thread as a request

Death Dealer: i have a dedicated server for gmod [you’re welcome to join] and when i try to join it says ‘server must update to most recent version’
Death Dealer: how do i update my gmod dedicated server using SRCDS and the HLSupdate tool
Death Dealer: you can copy and paste what i just said above
Death Dealer: post it in the gen discussion for hl2
Death Dealer: the specific based forums within the general hatdly get any answers
Death Dealer: this is kinda an emergency cuz im inviting all my peeps for some ghost hunting on this cool new map but my server is out ot date, and idk how to update it

windows or linux based?

Windows

hldsupdatetool.exe -command update -game garrysmod -dir whatever

hldsupdatetool -command update -game “tf” -dir .

hldsupdatetool -command update -game “episode1” -dir C:\HLServer

hldsupdatetool -command update -dir <yourdirectory> -game “garrysmod” -verify_all -retry

:toot: