Server Nav/Errors

Back again with another problem, this time more confusing for me.

After my friend had bought his server, I started to work on it. When I thought it was ready, I get this in the console:

Fetching Workshop Addons…
Calling GetCollectionDetails
Collection has 16 Addons
Mounting Addon ‘[TFG] Rp_TFG_HaloRP Official Map’ (346867828)
Mounting Addon ‘NutScript Content’ (207739713)
Mounting Addon ‘Halo 4 Weapons’ (281600480)
Mounting Addon ‘Halo:Reach Weapons’ (267868561)
Mounting Addon ‘Halo 3 - Arbiter’ (154058323)
Mounting Addon ‘Halo: CE Spartan Player Model’ (348923474)
Mounting Addon ‘Halo 3 Spartan Playermodels (MPSC)’ (283815805)
Mounting Addon ‘Halo: Reach Elite Playermodels/NPCs + Kinect conversion’ (195216064)
Mounting Addon ‘Emplacements’ (213515639)
Mounting Addon ‘Halo Reach ODST’ (311681055)
Mounting Addon ‘Halo Reach: Noble 6 (Playermodel/NPC/Ragdoll)’ (423711983)
Mounting Addon ‘Halo Reach Spartans (Updated)’ (236810890)
Mounting Addon ‘ODST Drop Pod’ (434936477)
Mounting Addon ‘Gmod Legs 3’ (112806637)
Mounting Addon ‘WAC Aircraft’ (104990330)
Mounting Addon ‘WAC Halo’ (178945066)
Can’t use cheat command nav_generate in multiplayer, unless the server has sv_cheats set to 1.
Changing gamemode to Halo Serious RP (halorp)
WARNING: Port 27005 was unavailable - bound to port 27018 instead
Network: IP 185.38.151.231, mode MP, dedicated Yes, ports 27105 SV / 27018 CL
Error loading cfg/trusted_keys_base.txt
Error loading cfg/pure_server_minimal.txt
PREP OK
NutScript has connected to the database.
Couldn’t include file ‘entities\base_wire_entity.lua’ (File not found) (@lua/entities/wac_seat_connector/init.lua (line 5))
Making workshop map available for client download
Using map cycle file cfg/mapcycle.txt.
Nav File is wrong or something (4)

Now, the server did come up once, and only once, before I restarted it again and it didn’t appear again. When the server was up and running, when we tried to join it said that out map differed from the server’s. That shouldn’t be happening. The map we’re attempting to use it “rp_tfg_halorp”. The server also refuses to print anything else after “Nav File is wrong or something (4)”. Can anyone assist my and say if I’m doing anything wrong?

Thanks!

P.S: Please tell me if I forgot to include a part of info needed to solve this.

The nav file is not important, nor do those errors mean anything in relation to your issue. Try disabling all of your addons and just starting up the server on Sandbox gm_construct.

Server still won’t come up on the list for some reason.

Can you connect to it?

We fixed it. We couldn’t connect, so we did the harder way and just reinstalled the server and put everything back where it needs to be. Thanks for helping.