Server not listed - 100$ Reward for solver

Hello Guys,

Since 2 weeks im trying to get my Rust-Experimental Server listened in the “Modded-Tap, History and Friends”.
I made a ton of research but not any method out there worked for me :frowning:

This is why i’ll give you 100$ on paypal if you can help me get the server listed.

Facts:

  • Server created with steamcmd “app_update 258550 -beta experimental”

  • installed Oxide

  • installed playrust.io

  • I’m using the following parameters to start the Server:
    “RustDedicated.exe -batchmode +server.hostname “TheOldDogs|TP|6XGATHER|Clans|Remove|BetterLoot|Instacraft” +server.port 28015 +server.identity “olddogs” +server.seed 272205 +server.maxplayers 100”

  • The Server works fine, i can connect with “client.connect 136.243.13.11:28015”

  • The Server is not listed in the Serverlist, dont show in History and in Friends.

  • The Firewall of the “Windows Server 2012 R2” is turned OFF so it cant block any ports.

  • Yes i turned the settings of the Extended Firewall all on pass so its everything open.

  • If i check with http://ping.eu/port-chk/ the port 28015 its open.

  • If i check with http://ping.eu/port-chk/ the port 28016 its closed.

  • If i check on playrust.io it displays my map correctly as it should, full functioning.

The server is located in Germany from the Provider “Hetzner” its an 64 Bit Win2012R2 Root-Server with 128GB Ram.
I’m running the Rust Server on it.

If you like to help me and gain those 100 bukks answer in the Forum or in Steam “Naked-Men Hunter”.

Thankyou for your Help in advance :slight_smile:
Lengro

you do not need to use parameters -beta experimental to the app_update, try to do this " app_update 258550 -validate " restart your server and try to connect again

No difference … installation gets validated “Fully installed”
Its still not listened nor is the Servername visible in the “Connection” Tab.

ok, can u try to change server port and rcon port, server.port 28018 and rcon.port 28019 and try again?

also, unless anything has changed, the server list only shows the first 200.

Yeah though, but it should still show in the History Tab and in the connection Tab too.

fuck trying to help you then. you have a nice day.

Don’t expect much help with an attitude like that. Be thankful anyone is trying to help at all.

Not sure if you’ve changed anything since your last post, but:

Rust/Steam use UDP - RCON uses TCP.

Servers only show in your History if you actually click on them and connect to them from the server list. Using client.connect doesn’t add them to your History. Similarly, using client.connect bugs the ‘Connection’ tab a little and (from memory) it won’t show the server name (presumably because this is set when you connect to a server through the server list).

mrknifey is very correct in saying that the server list only shows 100-200 servers - it’s sort-able (ping/players/server name), but not filterable. This means that if your server falls outside of this limit, it won’t be shown - ever.

I would always advise specifying all of the command line parameters - this includes +server.ip (+server.ip 177.54.146.134 in your case). Although you say you have no firewall open, make sure your game port (specified on +server.port) is viewable from the outside and also your +server.port+1 (28016 in your case). Steam uses +server.port+1 to communicate to / from your server.

Not nice answer it’s right…but mate…can’t even connect on your server…

Yeah, just changed the port to 28018 gonna change it back now :slight_smile:
Thx for your help

[editline]9th April 2015[/editline]

I did add the server.ip into the batch.

Just a guess, if everything is working i should be able to get Serverinformation of the normal Steam-Serverbrowser in the favorites if i add the ip?
Because i get there a “no response of the Server”.

And the 28016 seems to be closed even with disabled firewall !?

Are you hosting from home? Your router might have a firewall, too.

No its in a serverfarm in germany. “http://www.hetzner.de

Have you contacted them to see if they are blocking the ports on their end?

I use this to start my test server for Rust 2.0.

RustDedicated.exe -batchmode +server.hostname “Test Server” +server.port 20480 +server.identity “facepunchdev” +server.seed 6738 +rcon.ip 192.168.0.70 +rcon.port 5757 +rcon.password pa$$word

Make sure to include the rcon.ip and rcon.port too.

Ensure the port used for the server, server + 1, and RCON port are all allowed if you’re using a firewall.
If you’re using port forwarding, ensure UDP is forwarded for the server port, and the server port +1, and TCP is forwarded for the RCON port.

So for the example above, ensure ports 20480, 20481 and 5757 are allowed through any firewall you may be using, and if necessary, forward those ports to the IP of the server too.

Take the | symbols out of your server’s name.

I just sent them a support ticket so in a few hours i should know that.

@elixwhitetail: I already took out those Symbols. It doesnt make any difference.
@JV: thx i already tried that before on 280125 and 280126. Doesn’t work either :confused:

Okay the official answer from my Serverprovider:

“We do not block any ports. So it must be a firewall rule on your server or on the source PC from which you try to connect.”

I hope you mean 28015 and 28016, because port numbers stop at 65535. If you have a six-digit number in your launch command for the port, that’ll be the whole problem right there.

Are you setting the rcon parameters like JV said?