"Server not responding" dedicated server

I keep getting problems with my dedicated server.
No one can join , only I can join via Local Network. I’ve set sv_lan to 0 , doesn’t help.
I’ve port forwarded already like 10 times , everytime it works for a week or so , and then it just shuts down and only I can join , with something like 2000 ping.
Another strange thing is that , when i reinstalled the whole server for the 5th time , it says im hosting it on 77.xxx.xxx.xx. After a week , it said im hosting on 192.xxx.x.x. Now it keeps saying 192 though.
Like I said , i’ve portforwarded already 10 times , reinstalled the whole server via steamcmd like 5 times and now i’m sick of it.

Ports i’ve forwarded:

When I finished typing this , I get a whole new error!

what is this madness

This means you are trying join a live server from a dev beta branch, or vice versa.

192.168.0.x means it is a local address, if you have that addresss its likely you need to look at your command line.

Uhm , what do you mean? I don’t understand the advanced language :confused:

[editline]16th March 2014[/editline]

It always worked with 192.xxx.x.x.

Command line:

Get off the dev branch is what Robotboy is saying.

And how do I do that?

If it works for like a week, it sounds like your IP is address is changing. You’d be best unblocking the port for several IP addresses. For some reason you’ve hidden your local IP, I assume you didn’t want to be DDOSed but that’s impossible unless we know your external IP which doesn’t begin with 192.168.

Assuming your IP address is something like 192.168.0.3, unblock ports for
192.168.0.1
192.168.0.2
192.168.0.3
192.168.0.4
192.168.0.5

etc

I’m not changing my IP adress, as far as I know…
I did put in my ethernet cable in my PC when I can , since it has faster internet. But when I run the server , I connect to my wireless internet again , since I originally hosted it on that.

Most routers assign a dynamic IP address, so your IP address will change sometimes when connecting to the network

And how can I solve that?

http://support.facepunchstudios.com/kb/articles/11-how-do-i-join-the-dev-branch

I looked at iT , And I never was in THE dev branch , according to steam.

What appid did you use to install your server with SteamCMD?

Also, try running an update.

app_install_dir E:\gmod

app_update 4020

i believe

i did try running a update , didnt work.

Can you post what your version number is in the top right of your GMod client?

14.01.14 I believe , The latest version.

Then it means your server is on dev branch.

[editline]18th March 2014[/editline]

Also, try validating both, your server and client.

And how can I get my server out of the dev branch?

Reinstall it normally.

All I have talked about is only applicable if this is the error you are getting when connecting to the server: