Server not responding to friends

Hello everyone, sorry if I seem a bit noobish, but I’m having problems getting my listen server to work. I lurked around on the forums a little bit and found some relevant topics, but nothing seems to work. I’ve used http://portforward.com/ to set up a static IP and forward the relevant ports (27014 - 27050 TCP, 4380 UDP, 27000 - 27030 UDP and 27015 TCP). I’ve also disabled all firewalls on my PC, and used PFPortChecker to test my ports, which reports that all the needed ports are open. Typing status into Gmod’s console reports that it’s using port 27015, which is open. However, to everyone else my server is not responding at all, and won’t respond to ping either. I’m at a loss for what to do, it seems I’ve done all I can yet it still won’t work. Does anyone have any ideas? Anything would be appreciated at this point.

Oh also I’m on a wireless network, so I’m not directly connected to the router. This shouldn’t affect anything though, should it?

Try this:

1: Click me.
2: Copy the IP address that you see on the top of the screen.
3: Distribute that address to your friends, and tell them to type it into console, preceded by “connect”, so it would look like the following:


connect 89.14.75.147

4: Once that’s over with, they should be able to connect.

If that’s what you’ve been doing, then I can’t help you beyond that.
It’s at least worth a shot.

Ok thanks, that worked! I tried it yesterday and it didn’t work, but since then I re-did all my port forwarding and it works now! Cheers :slight_smile: