Server Not Responding.

So, earlier i had an issue were, as far as i could tell, the server was lan only. I have fixed that now, but the same error occurs to other players, “Server Not Responding”, earlier it said “Cant ban users on lan” in console, i resolved that error, can any one help thanks :wink:

Are you sure you’ve properly port forwarded?

I will list the ports tommorow and every bit of information I can go off.

Ports Are

Use http://canyouseeme.org to check if your port is open

I once again must repeat that these “check if my port is open” tools are not 100% accurate. It tells me that all of my ports are closed even though I can host a GMod server.

As for the problem, port forwarding is only part of the problem. Even if you do it correctly, you still must disable any firewalls that might be blocking the connection.

By firewall you mean the ones in my hub settings were i set up the ports.

By firewall I mean any firewall software you have in your whole network.

This includes but not limited to Router Firewall(s), Antivirus Firewall(s) and Standalone Firewall(s)

Ok i saw this when restarting my server in the console:

authkey is not a concommand, its a parameter, eg -authkey

i disabled my firewall, not difference…

[editline]17th August 2015[/editline]

Yes, thanks.

[editline]17th August 2015[/editline]

But still no diffidence no one can join but me.

I once had the problem with my ports too, try instead of directly setting the rage to 2050, to just take 27015 on UDP & TCP Like this:

I dont understand :confused:

[editline]17th August 2015[/editline]

I have closed all fire walls etc, not helping i cant even connect through the IP, can only connect through Local network

Servers you host with your computer won’t show you in the server browser, only in the Local Network tab. This doesn’t necessarily mean others can’t see it.

Once you’ve port forwarded the default 27015, try disabling Windows’ firewall, or any other anti-virus you might be running. Start the server first so that it takes the 27015 port then start Gmod. Gmod then will take 27016. Afterwards ask someone on Steam to see if they can view the game info, this can simply be done using the steam chat ui.

Also, as someone said before, instead of setting port ranges, try portfowarding just one ( 27015 ) tcp and udp.

Either im not doing this right or its not working

also ensure sv_lan is 0, lol!

Dont you see? Something is already using the port forwarded ports, close all old servers, everything useless and try running your server. If you dont get the warning port was unavailable, go check from canyouseeme port 27015.

Usually when I get such messages, my server still works fine, and is somehow accessable on port 27015.