Server not running as darkrp

Not sure where I should try and post this since well… there’s no specific section for server help at all so this is the best place possible

files have these in them V

server.cfg

http://puu.sh/jF259/43f6906ee0.png

autoexec.cfg

http://puu.sh/jF27H/fc4531cabf.png

start.sh (start script)

http://puu.sh/jF2l3/d1658e6b0b.png

problem

http://puu.sh/jF2gq/212cc51954.png

I’ve tried them lowercase and like how they are shown above, nothing seems to be working… It’s a linux server.
My local server (windows) works fine and launches as darkrp but this one won’t for some reason.

autoexec.cfg:

gamemode “DarkRP”

Done.

It’s still sandbox.

http://puu.sh/jF6ZE/2c4be26909.png

check the gamemodes/ folder then, and see the actual folder name, try fully lowercase.

[editline]17th August 2015[/editline]

oh and try in the commandline
+gamemode “darkrp”
with ".

This should work. For whatever reason its case sensitive.

meh, I dont mind it being case sensitive, since I always rename everything lowercase, just to prevent conflicting or such.

Go inside darkrp folder. There should be a .txt file. Make sure that is the same name as the folder.
Lets say the text file is named darkrpgm.txt make sure the folder is the same name (no .txt, obviously :P) and do


+gamemode darkrpgm

[Honestly I don’t know if the folder name matters, but just stay on the safe side.]

Everything is set to DarkRP including that file and folder it’s just not working and it’s pissing me off.

Firstly I think that this is case sensitive so make sure that you have everything as the correct case. Secondly I don’t believe sv_gamemode or sv_defaultgamemode work in GMod 13 so I think you should be using gamemode “darkrp” instead.

http://puu.sh/jFxKx/3291e56494.png

Tried it capital and lowercase and the folder is DarkRP then the .txt is DarkRP

gamemode is always lower case.
darkrp not DarkRP (Should be the folder’s name in garrysmod/gamemodes)

Maybe i should point this out a bit more

http://puu.sh/jFyPm/802d671e67.png

Literally all the server files are copied from my local srcds server to the linux server exactly and the windows server(local) is working fine and being set to the correct gamemode.

Well if it’s Linux and you said the folder name is DarkRP, obviously it’s not loading.
Change the folder name to darkrp and try again.

As we said above, change the folder to lowercase, specially if its on linux, I always did that and it worked fine(Also, dont forget to change the “DarkRP.txt” to lowercase too!)