Server not showing up on browser/masterlist.

Hey,

So I’ve bought a VPS lately, running on Windows Server 2008 R2.
I’ve installed SteamCMD, downloaded a gmod server, the server works fine, people can connect, but only one problem though; the server is not showing up on master list.
I’ve tried restarting the server many times, restarting machine, re-installing os, re-installing srcds, but it still won’t show up. However besides that the server works fine as I said.

Server.cfg is empty.

Running .bat script:



@echo off
cd c:\srcds
echo Starting game server.
echo Beginning "Garry's Mod"
srcds.exe -console -tickrate 66 -game garrysmod +map gm_construct +maxplayers 30 +hostname "Dev" -port 27015
echo "Garry's Mod" has now started.
echo It is recommended that you start Server Crash Recovery aswell.


Can you please give me a hand?

This is a global GMod issue; there is no definite fix.

Well, it doesn’t seem like a problem in gmod but in the host i’m using since on another one it worked fine.

A question for people who might see this and used NFO before;
Is there anything blocked by default in the configuration or something? Because I’ve tried putting up a server on another host ( I still prefer NFO because they offer more and are more convenient ), and it doesn’t have that problem, and I’ve already tried contacting the support, and they gave me various solutions but they didn’t work. Any idea what the problem might be? Is it something that I’m missing on a windows install?

Try entering this into server console: heartbeat
This is unneeded: -tickrate 66
Tickrate is 66 by default
Did you wait until the search stopped?
Try adding -ip <publiciphere> command to the commandline parameters

Already tried all those :confused:

Then you should’ve mentioned it in your post.

Have tried those after I’ve posted the topic, and forgot to edit. Sorry.

Is it similar to this issue, where the server doesn’t show up unless the user has ticked “has users playing” ?

Now that you mention that I’ve checked and indeed, it only shows up ( in the legacy browser ) if I check has users playing on it.

New server list is shit in general, garry won’t accept any sort of pull request to change it though.

How come however that the other host had it fine, does the glitch happens randomly?

Randomly

[editline]8th January 2014[/editline]

I believe it will show up if you have a sizable amount of players, however.

Do you find the solution?

As it’s stated over this entire thread, there are no solution for this.

where do i put -tickrate 66 and the -ip thing