Server rebooting every 5 minutes.

Okay, so, I can think it’s happening via the actual server itself.

Restart SYSTEM 127.0.0.1 Monitoring (max query not responding)
That’s what I got when I checked logs, and as I suspected, it’s every 5 minutes.

There aren’t any leaked addons, they’re all bought and paid for.

I’m honestly stuck on why it’s doing this.

Any help would be gladly appreciated, thanks.

Is there a specific point when this started happening? As in after the installation of a certain mod/script?

Leading on from Amaurus, perhaps try removing all your addons.

Yep, I know you won’t want to do that. Which is okay. Here are two workarounds of disabling all your addons on a server without actually removing them:

If you are using a Linux server:
a) Rename the “addons” folder to “ADDONS”.
b) If that doesn’t work, rename all of the addon folders into caps. Linux servers don’t seem to like caps.

Then, remove your collection ID from the startline, and reboot the server, and wait.

If renaming the folders doesn’t work / you are on a windows server:

Create a folder inside of the addons folder and put all the other folders inside.

Then remove the collection ID from the commandline.

If this doesn’t work see if the same errors happens.

You really want the opposite, you want all your folders in lowercase, NOT “CAPS” or uppercase.

It happens at certain times of the day, for example, 12am GMT -0 time.

The server right now, hasn’t restarted since 1pm GMT.

Linux paths are case sensitive, and gmod for some reason doesn’t take into account or use upper-case paths, so putting them in UPPERCASE would disable your addons, as Feldma said. - ( although with Linux I’d always suggest using lower-case path names as it’s just tidier and causes less problems with people developing for windows in mind )

**Robotboy **- you’re right if we’re looking to enable addons, but he was looking to disable them, hence the uppercase suggestion.

However, this is a very long-winded way to do it. What you said about the windows server is the fastest and will work on Linux to - To disable all your addons:

  1. Remove your collection ID from the start up script / command line.
  2. Go to garrysmod/addons - create a New Folder - uppercase characters will make sure nothing loads, but it shouldn’t load anyway.
  3. Move all addons and .gma files into the new folder.
  4. Restart server, leave up for a while and see if it restarts.

If that doesn’t work, and you’re running this on a VPS / Dedicated, a few more things to try:

  • create a new Garry’s Mod server without ANY addons or modifications, and leave it up for a while - see if this one restarts.
  • if the above DOES work, add the game-mode you’re running back in - still WITHOUT any add-ons, and see if it restarts.
  • then add in your workshop collection - LEAVE OUT CUSTOM ADDON FOLDERS - and see if it restarts.
  • finally add back in your individual folder addons - see if it restarts.

It sounds like it could be either addons, map, server-setup - if you do the above steps, at one point it SHOULD start restarting again, at that point you know it’s one of the things included in what you just added - either the server itself, the game-mode, the workshop collection or the addons.

When you find out what one it is, if it’s addons it’s easy, just start from scratch and slowly place the folders back in a few at a time. If it’s the collection, it’s slightly more difficult, but same again just start adding them in slowly.

Tedious work - but you should be able to find the source.

If it’s shared hosting - as in game server hosting - do the same as above and remove all addons, but if it’s still restarting - you might need to contact the host and ask them to re-install your game-server as you have problems with it ( save any data you need first obviously ).

Sorry - read OP again - do you mean the actual BOX is restarting, or do you think it’s just the game server?

This has happend to me too, after several reinstalls i had to close my server, instead starting a perp server… I had a darkrp server aswell, it said the same error, even got my server transfered to a new BOX

I am SO sorry, I completely forgot about this thread.

It happens at night, mainly around 10-11PM, I don’t know why.
It’s started it again, hence why I’m looking for advice.

We have all the addons in and everything, it was working fine earlier.
It literally just reboots at certain times, like now, it’s rebooting every 5 minutes.
I’ve checked over EVERY .gma, and all of the server files, there’s no script that’s running on a timer to kill/reboot/stop and then start the server.

I looked in the logs, it seems like it’s the server.
It’s pissing me off, because we literally lost 11 players due to reboots.

I’m so fucking stressed, because there’s no code to reboot anywhere at all.
And I’ve checked over everything via Sublime Text.

[editline]10th May 2016[/editline]


5/10/2016 5:31:39 PM	Stop	SYSTEM	127.0.0.1	Monitoring (query not responding) script
5/10/2016 5:31:42 PM	Start	SYSTEM	127.0.0.1	Monitoring (query not responding) script
5/10/2016 5:37:25 PM	Stop	SYSTEM	127.0.0.1	Monitoring (query not responding) script
5/10/2016 5:37:28 PM	Start	SYSTEM	127.0.0.1	Monitoring (query not responding) script
5/10/2016 5:43:10 PM	Stop	SYSTEM	127.0.0.1	Monitoring (max query not responding) script
5/10/2016 5:43:13 PM	Start	SYSTEM	127.0.0.1	Monitoring (max query not responding) script
5/10/2016 5:43:19 PM	Restart	SYSTEM	127.0.0.1	Monitoring (max query not responding)
5/10/2016 5:49:00 PM	Stop	SYSTEM	127.0.0.1	Monitoring (max query not responding) script
5/10/2016 5:49:03 PM	Start	SYSTEM	127.0.0.1	Monitoring (max query not responding) script
5/10/2016 5:49:10 PM	Restart	SYSTEM	127.0.0.1	Monitoring (max query not responding)
5/10/2016 5:54:49 PM	Stop	SYSTEM	127.0.0.1	Monitoring (max query not responding) script
5/10/2016 5:54:52 PM	Start	SYSTEM	127.0.0.1	Monitoring (max query not responding) script
5/10/2016 5:54:58 PM	Restart	SYSTEM	127.0.0.1	Monitoring (max query not responding)
5/10/2016 6:00:38 PM	Stop	SYSTEM	127.0.0.1	Monitoring (max query not responding) script
5/10/2016 6:00:41 PM	Start	SYSTEM	127.0.0.1	Monitoring (max query not responding) script
5/10/2016 6:00:48 PM	Restart	SYSTEM	127.0.0.1	Monitoring (max query not responding)
5/10/2016 6:06:27 PM	Stop	SYSTEM	127.0.0.1	Monitoring (max query not responding) script
5/10/2016 6:06:30 PM	Start	SYSTEM	127.0.0.1	Monitoring (max query not responding) script
5/10/2016 6:06:36 PM	Restart	SYSTEM	127.0.0.1	Monitoring (max query not responding)

That’s what I’m getting in the logs.

[editline]10th May 2016[/editline]

It isn’t an addon, there are no workshop addons, either.

Don’t you have actual server logs? Your game server provider probably lets you enable them (or you can just put -condebug in the command startup parameters). It’ll create a file called console.log that you can check out for issues once the crash happens again.

It isn’t a crash.
It’s an auto-reboot script for every 5 minutes.

It sounds like an issue with your provider then. If the server isn’t actually crashing and some third-party script is restarting it, we can assume that script is doing something wrong?

Just narrowed it down to either.

banned_user.cfg
banned_ip.cfg
server.cfg.

One of those three was making it reboot.

[editline]11th May 2016[/editline]

It was the server.cfg, no idea why.