Server startup crash issue! HELP!

So I decided to make a GMOD server for me and my friends. I followed this video here:https://www.youtube.com/watch?v=zjzTGyzcOvo&feature=iv&src_vid=i-1c0NQtBIE&annotation_id=annotation_2776214465. It worked once before but I decided to make a whole new server today and what not. When I make the server and follow that video, when I open my star.bat file, it will load and crash and it will keep opening and crashing until I close it. It then gives me a srcds_2117155-crash. Here is what the command prompt looks like: http://postimg.org/image/wzpzuljjp/
and here is what the crash looks like: http://postimg.org/image/i6s8w5z7r/
Keep in mind this is a fresh server with no addons installed. Pleas help me figure this out! :smile:
Here is the code in my start.bat btw
@echo off
cls
echo Protecting srcds from crashes…
echo If you want to close srcds and this script, close the srcds window and type Y depending on your language followed by Enter.
title srcds.com Watchdog
:srcds
echo (%time%) srcds started.
start /wait srcds.exe -console -game garrysmod +map gm_construct +maxplayers 16
echo (%time%) WARNING: srcds closed or crashed, restarting.
goto srcds

anyone?

Do you already have a server running on the machine?

Have you tried validating the server using SteamCMD by adding validate to the end of your app_update command?

Well I used to have a server running on my pc. Then I tried to run it one day and it gave me that error. I then tried the validate thing on the server but it didn’t work. So I deleted the whole server except the addons I added to the server and what not. I then made a whole new server and it is still giving me this stupid error.
what I notice is that it is trying to find addons or something but I don’t have any addons installed.

Try doing it without any addons, and simply using validate on steamcmd then running the server. See what happens

so I open up steam cmd and type
app_update validate?

[editline]19th July 2015[/editline]

Btw this is what my server looks like as of now.
Here is my addons folder (nothing in it): http://postimg.org/image/aasqyxh4t/
And here is what my main server folder looks like when I installed: http://postimg.org/image/9abm3cgpn/

Open up steam cmd, type login anonymous, then type force_install_dir C:\gmod\ and then type app_update 4020 validate

Ok i’ll try that. Thank you guys for helping.

[editline]19th July 2015[/editline]

Ok here what it looks like when I validate it: http://postimg.org/image/5ydi27zst/
and unfortunately it did not work and I honestly have no idea what’s going on…

I hesitated to help you because I saw you were using internet explorer (joking)
You need to tell us why exactly it isn’t working. What does the console say after running your run.bat?

look at the images I provided. right when it gives me an error, it will close less then a second.

I’m honestly stunted. It may be an engine error or some shit with the update that doesn’t connect with the drivers. I’m not exactly knowledgeable in the SRCDS side, apologies. Or maybe it’s a faulty version of SteamCMD

Use this command line:

start srcds -console -game garrysmod +gamemode sandbox +map gm_construct +maxplayers 16

This command line works for me because I can run my own server. Also, when updating or installing a server with steamcmd, use app_update <AppID> validate.

Yeah it might. Could you possibly send me a new version of CMD? and thank you guys for trying to help me :happy:

Can you post like a full log of the server from start to the final crash/error message? also what specs/windows version is the server running?

Just download another copy of steamcmd here but install it somewhere like Documents/SteamCMD, and install your server in Documents/GmodServer and go from there.