Server Startup Errors

Hello,

I’ve never had these issues before, but recently re-install my Ubuntu 14.04 Server and now am getting these on startup. I’m used to getting the 32 libraries error - which I have fixed, however still have these. I’ve separated off the two chunks that I don’t recognize, if anyone could point me in the right direction I’d appreciate it.

I also have similar errors when installing the server using SRCDS. I’m guessing there’s something I’m missing on the server. I’ve re-installed the box a few times already and haven’t had these errors as far as I can remember.

I understand that this is technically a SRCDS issue and not Gmod - but if anyone has come across them before I’d really appreciate a pointer.



Auto detecting CPU
Using default binary: ./srcds_linux
Server will auto-restart if there is a crash.
WARNING: Failed to locate steam binary.
WARNING: Could not locate steam binary:, ignoring.
Couldn't load shader dll: game_shader_generic_garrysmod_srv.soConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "Garry's Mod"
Setting breakpad minidump AppID = 4000
Initializing Steam libraries for Workshop..

=================================================
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Could not find steamerrorreporter binary. Any minidumps will be uploaded in-processapplicationmanager.cpp (3086) : Assertion Failed: CA
Assert( Assertion Failed: CApplicationManager::GetMountVolume: invalid index ):applicationmanager.cpp:3086
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20160228121740_4.dmp
success = no
error:  libcurl.so: cannot open shared object file: No such file or directory
applicationmanager.cpp (3086) : Assertion Failed: CApplicationManager::GetMountVolume: invalid index
applicationmanager.cpp (3237) : Assertion Failed: m_vecInstallBaseFolders.Count() > 0
=================================================

Fetching Workshop Addons.. No -authkey
Unknown command "cl_cmdrate"
Unknown command "cl_updaterate"
Unknown command "rate"
Unknown command "port"
Network: IP 88.150.197.34, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
Error loading cfg/trusted_keys_base.txt
Error loading cfg/pure_server_minimal.txt
PREP OK
ConVarRef room_type doesn't point to an existing ConVar
Executing dedicated server config file server.cfg
Using map cycle file cfg/mapcycle.txt.\
Nav File is wrong or something (4)
Initializing Steam libraries for secure Internet server

=================================================
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Could not find steamerrorreporter binary. Any minidumps will be uploaded in-processapplicationmanager.cpp (3086) : Assertion Failed: CA
Assert( Assertion Failed: CApplicationManager::GetMountVolume: invalid index ):applicationmanager.cpp:3086
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20160228121744_4.dmp
success = no
error:  libcurl.so: cannot open shared object file: No such file or directory
applicationmanager.cpp (3086) : Assertion Failed: CApplicationManager::GetMountVolume: invalid index
applicationmanager.cpp (3237) : Assertion Failed: m_vecInstallBaseFolders.Count() > 0
=================================================

No account token specified; logging into anonymous game server account.  (Use sv_setsteamaccount to login to a persistent account.)
Connection to Steam servers successful.
   Public IP is 88.150.197.34.
Assigned anonymous gameserver Steam ID [A-1:3914455048(6444)].
VAC secure mode is activated.
Sun Feb 28 12:17:47 GMT 2016: Server Quit



In-case anyone else had this issue - I seem to have fixed it by doing the following ( I remember doing this before - need to start recording these things myself! )