Server still stuck on LAN after portforwarding

I have been trying to make a garry’s mod server for allmost a year now, and i have looked at hundreds of threads about servers, but all of them say that if your server is stuck on LAN then you should port forward and i have used the port forwarding tool from portforward.com and it says the ports needed are open but garry’s mod is STILL on lan.

please help :frowning:

See if somone else can join.

make sure the server isn’t sv_lan 1

you can’t change that ingame in gmod, so make sure you either do it in the console before starting a server or in the settings when creating a listen server

no one else can join, people still cant join after sv_lan 0 and its a dedicated server

Add me to steam. Whosdr

hey, whosdr. im having the same problem. mines dedicated as well. i used the gmod wiki to help with my dedicated server and it still wont show. i added you on steam see if you can help me out. thanx

I figured out that port forward can’t help me at all. So I opened the following ports that no one seems to have mentioned.

27000 - 27015 TCP
27020 - 27029 UDP & TCP
26900 - 26950 UDP & TCP

I opened those and it worked.

Ports i use:

27015 - 27020 UDP and TCP
27005 - 27005 UDP and TCP

Listen uses:

27015 - 27020 UDP and TCP
1200 - 1200 UDP and TCP
27039 - 27039 UDP and TCP
27005 - UDP and TCP

My server ports work…so. Also you cant tell if it is lan or not. Just because u can see it on the LAN list doesn’t mean anything. You will c it there because YOUR hosting it, its going through YOUR router.

i forwarded those ports aswell and one of my friends tried to connect and then timed out

Client “[FH] STrotter583{SMAKA}” connected (86.160.161.108:27005).
INIParser:new - File stargate/gatespawner_maps/gm_flatgrass.ini does not exist!
Dropped [FH] STrotter583{SMAKA} from server ([FH] STrotter583{SMAKA} timed out)

and i cant find my server on the server list

in the config folder make a file named server.cfg if it isn’t there.

Sample:



hostname "[CB]Chewy's Serious Build Server #1"
rcon_password "censorcensorcensor"
ip 68.34.175.252:27016
Hostport 27016
***sv_lan 0
heartbeat***
sbox_noclip "1"
sbox_godmode "0"
sbox_plpldamage "0"         Turns on damage- It looks wierd because you think it'd have to be "1"
sbox_maxprops "999"
sbox_maxragdolls "999"
sbox_maxvehicles "999"
sbox_maxeffects "999"
sbox_maxballoons "999"
sbox_maxnpcs "0"
sbox_maxdynamite "5"
sbox_maxlamps "999"
sbox_maxlights "999"
sbox_maxwheels "999"
sbox_maxthrusters "999"
sbox_maxhoverballs "999"
sbox_maxbuttons "999"
sbox_maxemitters "2"
sbox_maxspawners "5"
sbox_maxturrets "3"
//rm_deathfix 0
//rm_ragdoll_damage 1
sbox_admin_nolimits 1
ASS_PropProtectAllowAdmins 0
sbox_weapons 0
sv_tags Wire,PHX,SBMP,Connastools,Serious,NoNoobs


it didnt work when i ut sv_lan 0 and heartbeat so i copied the whole thing and changed ip and hostport and stil my friend cant join

NOTHING WILL WORK

Have you tried giving them the IP and getting them to connect through the console? I can host fine but most people have to join through the console.

Are you using a static local IP and forwarding the port to the right one?

Guys I am having the same problem I have a ZyXEL P-660HW-D1 v2 router. I could host just fine with my previous one. I know my ports are open! I’ve checked them with a program. My firewall is off. I think im having the same problem as OP. I’ve also tried all the suggestions here.

i asked my friend to join through the console but he still timed out, i am using a static ip and the ports are forwarded from the static ip

Enable bridge mode on your modem.

HAVE MY FUCKING KIDS…IVE BEEN TRYING TO FIX THIS FOR AGES! thank you so much, really ive been raging over this.

Don’t give him your local ip, it fails, check your IP on something like http://www.whatismyip.com/ and tell your friend to connect thenumberyouget:27015

how do you do it in settings???

Well, if he joined its working. You just have a file error.

A file error as in a file in addons? Or just update the server?
and what is bridge mode?