Server sv_downloadurl set up and working, won't send maps to client.

Title.

I have sv_downloadurl set up to my locally hosted wamp server, an alias link set up to a folder called “gmodcontent”

Inside there, I have all maps on my server in the maps folder, it still refuses to upload any maps to the client.

I know it’s working because the (lua) cache is being send fine, as is other material stuff.

have you got it so its gmodcontent/maps or gmodcontent/cache etc?

Naturally.

I dicked around on the server a bit but it still refuses to send maps.

I have no goddamn CLUE what it is, its sending everything fine except for maps.

[editline]4th November 2010[/editline]

:iiam:

net_maxfilesize?

no maps are exceeding filesize, (otherwise that error would’ve been given anyhow)

PM me teamviewer information or something and I’ll look into it for you.

Uh, no thanks.

snip

Attempted bumping while thread was still on top of the list :v:

Edit: hurr durr I have nothing better to do then lurk threads and give boxes

Your retarded since your rejecting help from a user. I’ve seen darksoul69 around and seems like a reliable/trustable person.

I’m not giving remote control to a random stranger, besides that, I don’t have an account on whatever he mentioned, third of all: what could he possibly find that I have not looked into on my computer.

Teamviewer is free, and you can require it to make you accept any remote connections before they are established.

If you are set on not letting me team view, please provide the following:

Your server.cfg;
A screenshot of the root directory of your Garry’s Mod server;
A screenshot of the root of the “gmodcontent” folder.


echo "BASIC OPTIONS EXECUTED"
"hostname"				"g1real's Private S."
"rcon_password"
"sv_password"			
"sv_region"				"3" // eastcoast: 0 - westcoast: 1 - south america: 2 - europe: 3 - asia: 4 - australia: 5 - middle east: 6 - africa: 7 - world: 255
"sv_lan"				"0"

echo "SET THE DOWNLOAD URL"
"sv_allowupload"		"1"
"sv_allowdownload"		"1"
"sv_downloadurl"		"http://g1real.com/garrysmod/"

echo "RATES LIMITED"
"sv_maxupdaterate"		"100"
"sv_minupdaterate"		"33"
"sv_maxcmdrate"			"100"
"sv_mincmdrate"			"33"
"sv_maxrate"			"15000"

echo "SBOX OPTIONS LIMITED"
"sbox_godmode"			"0"
"sbox_plpldamage"		"0"
"sbox_noclip"			"0"

"sbox_maxprops"			"0"
"sbox_maxragdolls"		"0"
"sbox_maxnpcs"			"0"
"sbox_maxballoons"		"0"
"sbox_maxeffects"		"0"
"sbox_maxdynamite"		"0"
"sbox_maxlamps"			"0"
"sbox_maxthrusters"		"0"
"sbox_maxwheels"		"0"
"sbox_maxhoverballs"	"0"
"sbox_maxvehicles"		"0"
"sbox_maxbuttons"		"0"
"sbox_maxemitters"		"0"
"sbox_maxspawners"		"0"
"sbox_maxturrets"		"0"

http://img192.imageshack.us/gal.php?g=gmod1.jpg

Edit: to clarify, the htaccess is actually an attempt to open up the folder more, it does not work with or without it.

This is why your maps are not downloading:

http://dsservers.net/images/SS-2010-11-05_01.44.54.th.png

Well, that’s one of the reasons anyway. You also should add net_maxfilesize 64 in the server.cfg.

I need to see the root garrysmod folder - the one with the maps folder and materials folder. Not the orangebox folder.

htaccess.htaccess should be just .htaccess… it won’t work otherwise.

net_maxfilesize doesnt matter - its already 64 by default, regardless, its not using that for fastdownload, and none of the map files exceed the default 16 mbit.

You’re also trying to access a map file that isn’t in the folder: good job

you cant name a file extension without an actual name in windows, (I’m pretty sure you cant in linux either, correct me if I’m wrong)

That also wasnt the orangebox folder, that was the root of my server, where it started.

I appreciate you trying to help though.

http://img576.imageshack.us/img576/7607/gmod3.jpg

It has to be .htaccess or it WILL NOT WORK.

What maps are in the folder so I can try downloading them.

Why dont you just browse to the folder.

Also: I will probably have to change the name of .htaccess to something else, but I cant be arsed, it doesnt matter though, considering I can download files trough my browser just fine.

Oh. I was getting a access forbidden error on all the other folders so I figured the maps was like that too, my bad.

…maps.htaccess? sigh. Anyway, humor me and put net_maxfilesize 64 in the server.cfg.

I honestly have no idea what the problem would be. You receive no error messages at all when you try downloading the map from the server?

shouldn’t

“sv_allowupload” “1”
“sv_allowdownload” “1”

be 0?

Doesn’t matter, his map is not downloading. Those settings wouldn’t affect map download.

I honestly have no idea either.

I tried the MiniTankWars fretta gamemode and for some particular reason it did download that map, some material files, but nothing else, all errors (didnt see any AddResource either in the lua files)

[editline]5th November 2010[/editline]

Pic related, it’s me humouring you.

http://img20.imageshack.us/img20/5949/ihumouredya.jpg

Edit: Fuck, I didn’t censor the lower part.

Now people will notice my favorite games and my activities, I will be HACKED!