Server Trouble

Hi all,
I purchased the alpha Rust this morning via steam. It starts up ok but when I get to the play game screen and all the servers load, it will not allow me onto any server. The server highlights red for a second but thats it. Ive cliked on every server and had the same result. Anyone else experience this? Or even better, anyone help me?

Audioslave, try to open console (F1)
And paste net.connect (ip) that might help…

Feel free to try out my server
net.connect 5.153.39.83:28115

Hi Dabliss. Firstly thank you for replying and your advice. Unfortunately im getting the same msg to each of your suggestions,
> net.connect 159.xxx.xxx.xx (ip)
> Not a valid ip - or port missing
command net.connect wad executed.

Have you tried my server ?
( you don’t have to stay, just try it )

Some guys posted on steam the same thing, and it worked for them. :slight_smile:

Hey, ye ive tried. Same reply as above. I really dont know what to try, 14 official servers showing and 3k community and not 1 can I use.

A multiplay:: Ireland (eu) server has appeared at the top of the community servers list, thos wasn’t there earlier. It has 0 players and yet I still cant join any servers. Is there a way to contact Rust support or something similar?

Still the same today. Anyone got any suggestions…I’d try anything at this point.

redacted